summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-05-03 09:07:02 +0200
committerRemi Collet <remi@php.net>2023-05-03 09:07:02 +0200
commit1c4ba48a76e58f77ef7fb19c6ce1a59a2de222b1 (patch)
tree046cc4d21cc2b368c8b194fcf1620bd2e0260d40
parenta9a6edd9a5ff09d80eb2b9c9ac8f26c5e3c9ac7d (diff)
update to 1.7.4 (no change)
-rw-r--r--composer.json6
-rw-r--r--php-tecnickcom-tc-lib-pdf-graph.spec13
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index cc936dc..2176709 100644
--- a/composer.json
+++ b/composer.json
@@ -25,12 +25,12 @@
"tecnickcom/tc-lib-pdf-encrypt": "^1.6.0"
},
"require-dev": {
- "pdepend/pdepend": "2.12.1",
+ "pdepend/pdepend": "2.13.0",
"phploc/phploc": "7.0.2 || 6.0.2 || 5.0.0 || 4.0.1 || 3.0.1 || 2.1.5",
"phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "9.5.27 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
+ "phpunit/phpunit": "10.1.2 || 9.6.7 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
"sebastian/phpcpd": "6.0.3 || 5.0.2 || 4.1.0 || 3.0.1 || 2.0.4",
- "squizlabs/php_codesniffer": "3.7.1 || 2.9.2"
+ "squizlabs/php_codesniffer": "3.7.2 || 2.9.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-graph.spec b/php-tecnickcom-tc-lib-pdf-graph.spec
index 4002629..598ddff 100644
--- a/php-tecnickcom-tc-lib-pdf-graph.spec
+++ b/php-tecnickcom-tc-lib-pdf-graph.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-graph
#
# Copyright (c) 2016-2023 Remi Collet
-# License: CC-BY-SA
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit df29ad8eb874a306858ee17973031d5b1c2755e0
+%global gh_commit d5c99f6a0a692248972dc4c912d5117d3176dcf3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.7.3
+Version: 1.7.4
Release: 1%{?dist}
Summary: PHP library containing PDF graphic and geometric methods
@@ -105,10 +105,10 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php80 php81 php82; do
+for cmdarg in "php %{phpunit}" "php80 %{phpunit}" php81 php82; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit10} --no-coverage || ret=1
fi
done
exit $ret
@@ -127,6 +127,9 @@ exit $ret
%changelog
+* Wed May 3 2023 Remi Collet <remi@remirepo.net> - 1.7.4-1
+- update to 1.7.4 (no change)
+
* Mon Jan 2 2023 Remi Collet <remi@remirepo.net> - 1.7.3-1
- update to 1.7.3