summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-pdf-filter.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-07-02 14:34:17 +0200
committerRemi Collet <fedora@famillecollet.com>2015-07-02 14:34:17 +0200
commitd15f63689524e65405bb21e9cecdde4302b323a2 (patch)
tree4e29fb4464178009c94d69f86a7ae8a13a56f4f9 /php-tecnickcom-tc-lib-pdf-filter.spec
php-tecnickcom-tc-lib-pdf-filter: 1.1.0 - New package
Diffstat (limited to 'php-tecnickcom-tc-lib-pdf-filter.spec')
-rw-r--r--php-tecnickcom-tc-lib-pdf-filter.spec113
1 files changed, 113 insertions, 0 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-filter.spec b/php-tecnickcom-tc-lib-pdf-filter.spec
new file mode 100644
index 0000000..d5fbf94
--- /dev/null
+++ b/php-tecnickcom-tc-lib-pdf-filter.spec
@@ -0,0 +1,113 @@
+# remirepo/fedora spec file for php-tecnickcom-tc-pdf-filter
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit ea313a032fa0207668f80c422ddadaf157e68ecd
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global c_vendor tecnick.com
+%global gh_owner tecnickcom
+%global gh_project tc-lib-pdf-filter
+%global php_project %{_datadir}/php/Com/Tecnick/Pdf/Filter
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.1.0
+Release: 1%{?dist}
+Summary: PHP library to decode PDF compression and encryption filters
+
+Group: Development/Libraries
+License: LGPLv3+
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
+
+Patch0: %{name}-pr1.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: %{_bindir}/phpunit
+BuildRequires: php(language) >= 5.3.3
+Requires: php-pcre
+Requires: php-zlib
+%endif
+
+# From composer.json, "require": {
+# "php": ">=5.3.3"
+Requires: php(language) >= 5.3.3
+# From phpcompatinfo report for version 1.4.5
+Requires: php-pcre
+Requires: php-zlib
+
+# Composer
+Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
+# Upstream package name
+Provides: php-%{gh_project} = %{version}
+
+
+%description
+PHP library to decode PDF compression and encryption filters.
+
+The initial source code has been extracted from TCPDF (http://www.tcpdf.org).
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+%patch0 -p1
+
+: Sanity check
+grep -q '^%{version}$' VERSION
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p $(dirname %{buildroot}%{php_project})
+cp -pr src %{buildroot}%{php_project}
+cp -p resources/autoload.php \
+ %{buildroot}%{php_project}/autoload.php
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat <<EOF | tee vendor/autoload.php
+<?php
+require '%{buildroot}%{php_project}/autoload.php';
+EOF
+
+%{_bindir}/phpunit --verbose
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.TXT
+%doc composer.json
+%doc README.md
+%dir %{_datadir}/php/Com
+%dir %{_datadir}/php/Com/Tecnick
+%dir %{_datadir}/php/Com/Tecnick/Pdf
+%{php_project}
+
+
+%changelog
+* Thu Jul 2 2015 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- initial package, version 1.1.0
+- open https://github.com/tecnickcom/tc-lib-pdf-filter/pull/1
+ fix autoloader \ No newline at end of file