summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-14 07:02:24 +0200
committerRemi Collet <remi@remirepo.net>2018-05-14 07:02:24 +0200
commitfa38e23437ce7cff9f0dc820b3ee2a61628fbd23 (patch)
tree7e62a4e2861fcc31e0a7860909140f534a2ba4f1
parentf2351040e47d615cefe6fe246d85efb34b8626ec (diff)
update to 1.3.7 (no change)
switch to phpunit7
-rw-r--r--composer.json12
-rw-r--r--php-tecnickcom-tc-lib-pdf-filter.spec19
2 files changed, 20 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 3187bd9..1fac879 100644
--- a/composer.json
+++ b/composer.json
@@ -25,13 +25,13 @@
},
"require-dev": {
"apigen/apigen": "^4.1.2",
- "bartlett/php-compatinfo": "^5.0.4",
- "pdepend/pdepend": "^2.5.0",
- "phploc/phploc": "^2.1.5 || ^3.0.1",
+ "bartlett/php-compatinfo": "^5.0.10 || ^5.0.12",
+ "pdepend/pdepend": "^2.5.2",
+ "phploc/phploc": "^2.1 || ^3.0 || ^4.0",
"phpmd/phpmd": "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd": "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
+ "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.1",
+ "sebastian/phpcpd": "^2.0 || ^3.0 || ^4.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.2.0"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-filter.spec b/php-tecnickcom-tc-lib-pdf-filter.spec
index 5d0ae80..3c67b20 100644
--- a/php-tecnickcom-tc-lib-pdf-filter.spec
+++ b/php-tecnickcom-tc-lib-pdf-filter.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit b2ca150f22ae550276acc57b3db4d6fc8d131dc7
+%global gh_commit c70929dec0140e6f4651547012480408b6b8e152
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.3.6
+Version: 1.3.7
Release: 1%{?dist}
Summary: PHP library to decode PDF compression and encryption filters
@@ -27,7 +27,12 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
Requires: php-pcre
Requires: php-zlib
@@ -82,10 +87,10 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -106,6 +111,10 @@ exit $ret
%changelog
+* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 1.3.7-1
+- update to 1.3.7 (no change)
+- switch to phpunit7
+
* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 1.3.6-1
- Update to 1.3.6 (no change)