summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-14 07:24:43 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-14 07:24:43 +0200
commiteb9ba6fa4296d0dc268f6ca86822dcb8ac10ba72 (patch)
tree18e819bf19bac06cd3749f29a9dcfb23acdf2887
parent19bdbdf5dc8e1da6e7eb69364cb057d7951a5ea8 (diff)
php-tecnickcom-tc-lib-pdf-filter: 1.3.0
-rw-r--r--composer.json33
-rw-r--r--php-tecnickcom-tc-lib-pdf-filter.spec7
2 files changed, 38 insertions, 2 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..330d497
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,33 @@
+{
+ "name": "tecnickcom/tc-lib-pdf-filter",
+ "description": "PHP library to decode PDF compression and encryption filters",
+ "type": "library",
+ "homepage": "http://www.tecnick.com",
+ "license": "LGPL-3.0",
+ "keywords": ["tc-lib-pdf-filter", "PDF", "filter", "encryption", "compression"],
+ "authors": [
+ {
+ "name": "Nicola Asuni",
+ "email": "info@tecnick.com",
+ "role": "lead"
+ }
+ ],
+ "require": {
+ "php": ">=5.4"
+ },
+ "require-dev": {
+ "apigen/apigen" : "^4.1.2",
+ "bartlett/php-compatinfo" : "^5.0.0",
+ "pdepend/pdepend" : "^2.2.2",
+ "phploc/phploc" : "^2.1.5|^3.0.0",
+ "phpmd/phpmd" : "^2.3.2",
+ "phpunit/phpunit": "4.8.19|^5.0.0",
+ "sebastian/phpcpd" : "^2.0.2",
+ "squizlabs/php_codesniffer": "^2.5.0|^3.0.0"
+ },
+ "autoload": {
+ "psr-4":{
+ "Com\\Tecnick\\Pdf\\Filter\\": "src"
+ }
+ }
+}
diff --git a/php-tecnickcom-tc-lib-pdf-filter.spec b/php-tecnickcom-tc-lib-pdf-filter.spec
index 5b7a212..2539c45 100644
--- a/php-tecnickcom-tc-lib-pdf-filter.spec
+++ b/php-tecnickcom-tc-lib-pdf-filter.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit a9ad0b4a14555b29e8194be9d07c7a168acb3ba7
+%global gh_commit 0aa2a8fe28e65fa354dcfeae5c85bc1bd6ae8ac9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.2.1
+Version: 1.3.0
Release: 1%{?dist}
Summary: PHP library to decode PDF compression and encryption filters
@@ -107,6 +107,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
+- update to 1.3.0 (no change)
+
* Fri Mar 4 2016 Remi Collet <remi@fedoraproject.org> - 1.2.1-1
- update to 1.2.1 (no change)