summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-pdf-encrypt.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-29 06:57:43 +0100
committerRemi Collet <remi@remirepo.net>2017-10-29 06:57:43 +0100
commita3603b015effffb4d9ea6e72616fe2eefb151393 (patch)
tree267e5bc52bfe318cd11d73f1b5c3faab723dc549 /php-tecnickcom-tc-lib-pdf-encrypt.spec
parentc1ca682590fecd48ed06e391d34ffffeb5f991aa (diff)
v1.5.3
Diffstat (limited to 'php-tecnickcom-tc-lib-pdf-encrypt.spec')
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt.spec37
1 files changed, 18 insertions, 19 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt.spec
index a3f2d98..884ba8f 100644
--- a/php-tecnickcom-tc-lib-pdf-encrypt.spec
+++ b/php-tecnickcom-tc-lib-pdf-encrypt.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 0da81c1f2ec073781e1650bc64915d26ff19ebe9
+%global gh_commit be185865d1ba7c29e43625cdeaf22cabb5ee2464
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.5.2
+Version: 1.5.3
Release: 1%{?dist}
Summary: PHP library to encrypt data for PDF
@@ -24,17 +24,21 @@ License: LGPLv3+
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php(language) >= 5.4
BuildRequires: php-date
BuildRequires: php-hash
BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-posix
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
%endif
# From composer.json, "require": {
@@ -43,12 +47,13 @@ BuildRequires: php-posix
# "ext-hash": "*",
# "ext-openssl": "*",
# "ext-pcre": "*",
-# "ext-posix": "*"
Requires: php(language) >= 5.4
Requires: php-date
Requires: php-hash
Requires: php-openssl
Requires: php-pcre
+# From composer.json, "suggest": {
+# "ext-posix": "*"
Requires: php-posix
# From phpcompatinfo report for version 1.5.0
# none
@@ -77,7 +82,6 @@ grep -q '^%{version}$' VERSION
%install
-rm -rf %{buildroot}
mkdir -p $(dirname %{buildroot}%{php_project})
cp -pr src %{buildroot}%{php_project}
cp -p resources/autoload.php \
@@ -94,14 +98,10 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmd in php56 php; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --no-coverage --verbose || ret=1
- fi
-done
-for cmd in php70 php71; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 --no-coverage --verbose || ret=1
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -110,12 +110,7 @@ exit $ret
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -127,6 +122,10 @@ rm -rf %{buildroot}
%changelog
+* Sun Oct 29 2017 Remi Collet <remi@remirepo.net> - 1.5.3-1
+- Update to 1.5.3
+- use phpunit6 when available
+
* Sun Feb 12 2017 Remi Collet <remi@fedoraproject.org> - 1.5.2-1
- update to 1.5.2 (no change)