summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-pdf-encrypt.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-14 06:59:40 +0200
committerRemi Collet <remi@remirepo.net>2018-05-14 06:59:40 +0200
commit766e1fbc50ff920e3fe4a22a57b89d2943f2ea6e (patch)
treeb5ccc7c567a04ffb5b0ad1ab7facf7b46b3387d1 /php-tecnickcom-tc-lib-pdf-encrypt.spec
parente970c8065ee1435d80067aedeec17ae3574513e8 (diff)
update to 1.5.6 (no change)
switch to phpunit7
Diffstat (limited to 'php-tecnickcom-tc-lib-pdf-encrypt.spec')
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt.spec16
1 files changed, 10 insertions, 6 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt.spec
index 880e439..8cc6b8f 100644
--- a/php-tecnickcom-tc-lib-pdf-encrypt.spec
+++ b/php-tecnickcom-tc-lib-pdf-encrypt.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 250ed40a343fcd2d5fbd2d11508f717b87d1b3cc
+%global gh_commit 9d27efc69b19ab5018c5dce9ad7b58a33cdd7f6b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.5.4
+Version: 1.5.6
Release: 1%{?dist}
Summary: PHP library to encrypt data for PDF
@@ -33,8 +33,8 @@ BuildRequires: php-hash
BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-posix
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
%else
%global phpunit %{_bindir}/phpunit
%endif
@@ -98,10 +98,10 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -122,6 +122,10 @@ exit $ret
%changelog
+* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 1.5.6-1
+- update to 1.5.6 (no change)
+- switch to phpunit7
+
* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 1.5.4-1
- Update to 1.5.4