summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-pdf-encrypt.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-10-23 13:49:00 +0200
committerRemi Collet <remi@php.net>2023-10-23 13:49:00 +0200
commit6ca779b2d0319ac54edc6350bcdf06ea7630c31f (patch)
tree74079097efc7548f19982a2e33455fd7995d1761 /php-tecnickcom-tc-lib-pdf-encrypt.spec
parent87ce2282cbe0224b8a9a42e250c58f3916f73cb2 (diff)
update to 1.6.35 (no change)
Diffstat (limited to 'php-tecnickcom-tc-lib-pdf-encrypt.spec')
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt.spec22
1 files changed, 17 insertions, 5 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt.spec
index 56dd087..8445b96 100644
--- a/php-tecnickcom-tc-lib-pdf-encrypt.spec
+++ b/php-tecnickcom-tc-lib-pdf-encrypt.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 5cdf890becb68c64f4c42dedde5c0d6dd4c0421b
+%global gh_commit b42d1fd2c7b0d6f42268d44690269bdf0ae2a700
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.6.33
+Version: 1.6.35
Release: 1%{?dist}
Summary: PHP library to encrypt data for PDF
@@ -32,9 +32,16 @@ BuildRequires: php-hash
BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-posix
+# remirepo:1
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
+%global phpunit %{_bindir}/phpunit10
+BuildRequires: phpunit10
+# remirepo:4
+%else
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.5.27
%endif
+%endif
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
@@ -98,11 +105,12 @@ VER=$(php -r 'echo (OPENSSL_VERSION_NUMBER>>28);')
if [ $VER -ge 3 ]; then
FILTER="--filter '^((?!(testEncryptPubThree|testEncryptPubNoP|testEncryptModZeroPub|testGetPdfEncryptionObjThreePub|testGetPdfEncryptionObjOnePub|testGetEncryptionData|testGetObjectKey|testEncryptStringEnabled|testEscapeDataStringEnabled|testGetPdfEncryptionObjOne|testGetPdfEncryptionObjZero)).)*$'"
fi
-for cmdarg in "php %{phpunit}" "php80 %{phpunit}" php81 php82 php83; do
+for cmdarg in php "php80 %{_bindir}/phpunit9" php81 php82 php83; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit10} --migrate-configuration || :
- $1 ${2:-%{_bindir}/phpunit10} $FILTER --no-coverage || ret=1
+ cp phpunit.xml.dist phpunit.xml
+ $1 ${2:-%{phpunit}} --migrate-configuration || :
+ $1 ${2:-%{phpunit}} $FILTER --no-coverage || ret=1
fi
done
exit $ret
@@ -112,6 +120,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -123,6 +132,9 @@ exit $ret
%changelog
+* Mon Oct 23 2023 Remi Collet <remi@remirepo.net> - 1.6.35-1
+- update to 1.6.35 (no change)
+
* Thu Oct 12 2023 Remi Collet <remi@remirepo.net> - 1.6.33-1
- update to 1.6.33