summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-02 09:46:24 +0100
committerRemi Collet <remi@remirepo.net>2018-01-02 09:46:24 +0100
commite970c8065ee1435d80067aedeec17ae3574513e8 (patch)
treed6b692a8ebc2f87e2e5aa5e25dbd790bad4bc855
parenta3603b015effffb4d9ea6e72616fe2eefb151393 (diff)
v1.5.4
-rw-r--r--composer.json81
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt.spec9
2 files changed, 50 insertions, 40 deletions
diff --git a/composer.json b/composer.json
index 8aa76c1..da90827 100644
--- a/composer.json
+++ b/composer.json
@@ -1,40 +1,47 @@
{
- "name": "tecnickcom/tc-lib-pdf-encrypt",
- "description": "PHP library to encrypt data for PDF",
- "type": "library",
- "homepage": "http://www.tecnick.com",
- "license": "LGPL-3.0",
- "keywords": ["tc-lib-pdf-encrypt", "PDF", "encrypt", "encryption", "AES", "RC4"],
- "authors": [
- {
- "name": "Nicola Asuni",
- "email": "info@tecnick.com",
- "role": "lead"
- }
- ],
- "require": {
- "php": ">=5.4",
- "ext-date": "*",
- "ext-hash": "*",
- "ext-openssl": "*",
- "ext-pcre": "*"
- },
- "suggest": {
- "ext-posix": "*"
- },
- "require-dev": {
- "apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.4",
- "pdepend/pdepend" : "^2.5.0",
- "phploc/phploc" : "^2.1.5 || ^3.0.1",
- "phpmd/phpmd" : "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
- },
- "autoload": {
- "psr-4":{
- "Com\\Tecnick\\Pdf\\Encrypt\\": "src"
- }
+ "name": "tecnickcom/tc-lib-pdf-encrypt",
+ "description": "PHP library to encrypt data for PDF",
+ "type": "library",
+ "homepage": "http://www.tecnick.com",
+ "license": "LGPL-3.0",
+ "keywords": [
+ "tc-lib-pdf-encrypt",
+ "PDF",
+ "encrypt",
+ "encryption",
+ "AES",
+ "RC4"
+ ],
+ "authors": [
+ {
+ "name": "Nicola Asuni",
+ "email": "info@tecnick.com",
+ "role": "lead"
}
+ ],
+ "require": {
+ "php": ">=5.4",
+ "ext-date": "*",
+ "ext-hash": "*",
+ "ext-openssl": "*",
+ "ext-pcre": "*"
+ },
+ "suggest": {
+ "ext-posix": "*"
+ },
+ "require-dev": {
+ "apigen/apigen": "^4.1.2",
+ "bartlett/php-compatinfo": "^5.0.4",
+ "pdepend/pdepend": "^2.5.0",
+ "phploc/phploc": "^2.1.5 || ^3.0.1",
+ "phpmd/phpmd": "^2.6.0",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
+ "sebastian/phpcpd": "^2.0.4 || 3.0.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Com\\Tecnick\\Pdf\\Encrypt\\": "src"
+ }
+ }
}
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt.spec
index 884ba8f..880e439 100644
--- a/php-tecnickcom-tc-lib-pdf-encrypt.spec
+++ b/php-tecnickcom-tc-lib-pdf-encrypt.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-encrypt
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit be185865d1ba7c29e43625cdeaf22cabb5ee2464
+%global gh_commit 250ed40a343fcd2d5fbd2d11508f717b87d1b3cc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.5.3
+Version: 1.5.4
Release: 1%{?dist}
Summary: PHP library to encrypt data for PDF
@@ -122,6 +122,9 @@ exit $ret
%changelog
+* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 1.5.4-1
+- Update to 1.5.4
+
* Sun Oct 29 2017 Remi Collet <remi@remirepo.net> - 1.5.3-1
- Update to 1.5.3
- use phpunit6 when available