summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-03 09:15:16 +0100
committerRemi Collet <remi@php.net>2022-01-03 09:15:16 +0100
commitb137e834390057d3994f36f65fb0918127ba7280 (patch)
tree67c2c0ba04d233d5f069a24548a0718daf6f0e5d
parentd456a071d36947ea5dac1c9e735e4f666f247b95 (diff)
update to 1.6.7 (no change)
-rw-r--r--composer.json8
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt.spec13
2 files changed, 12 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 6a18348..ded0854 100644
--- a/composer.json
+++ b/composer.json
@@ -30,12 +30,12 @@
"ext-posix": "*"
},
"require-dev": {
- "pdepend/pdepend": "2.8.0",
+ "pdepend/pdepend": "2.10.2",
"phploc/phploc": "7.0.2 || 6.0.2 || 5.0.0 || 4.0.1 || 3.0.1 || 2.1.5",
- "phpmd/phpmd": "2.9.1",
- "phpunit/phpunit": "9.5.0 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
+ "phpmd/phpmd": "2.11.1",
+ "phpunit/phpunit": "9.5.11 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
"sebastian/phpcpd": "6.0.3 || 5.0.2 || 4.1.0 || 3.0.1 || 2.0.4",
- "squizlabs/php_codesniffer": "3.5.8 || 2.9.2"
+ "squizlabs/php_codesniffer": "3.6.2 || 2.9.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt.spec
index 77d6295..de72e28 100644
--- a/php-tecnickcom-tc-lib-pdf-encrypt.spec
+++ b/php-tecnickcom-tc-lib-pdf-encrypt.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-encrypt
#
-# Copyright (c) 2016-2021 Remi Collet
+# Copyright (c) 2016-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit a432f1fa829ade1babc42968dad9a5112e6d3d7c
+%global gh_commit 8d55aad6ddaaed7148dba8ff1595b7d287c06b5b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,8 +15,8 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.6.4
-Release: 2%{?dist}
+Version: 1.6.7
+Release: 1%{?dist}
Summary: PHP library to encrypt data for PDF
License: LGPLv3+
@@ -103,7 +103,7 @@ VER=$(php -r 'echo (OPENSSL_VERSION_NUMBER>>28);')
if [ $VER -ge 3 ]; then
FILTER="--filter '^((?!(testEncryptPubThree|testEncryptPubNoP|testEncryptModZeroPub|testGetPdfEncryptionObjThreePub|testGetPdfEncryptionObjOnePub|testGetEncryptionData|testGetObjectKey|testEncryptStringEnabled|testEscapeDataStringEnabled|testGetPdfEncryptionObjOne|testGetPdfEncryptionObjZero)).)*$'"
fi
-for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} $FILTER --no-coverage --verbose || ret=1
@@ -127,6 +127,9 @@ exit $ret
%changelog
+* Mon Jan 3 2022 Remi Collet <remi@remirepo.net> - 1.6.7-1
+- update to 1.6.7 (no change)
+
* Thu Nov 11 2021 Remi Collet <remi@remirepo.net> - 1.6.4-2
- skip test failing with OpenSSL 3.0 reported as
https://github.com/tecnickcom/tc-lib-pdf-encrypt/issues/10