summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-21 10:52:56 +0100
committerRemi Collet <remi@remirepo.net>2020-12-21 10:52:56 +0100
commita5fb19ff40404b23a494e80f313b4ade4f27cee3 (patch)
tree5f683a6a45ab3425d3eec09c9296ecbf808c5cf6
parent845c94e67e67735cf36b90ea14b0b475eacb7ea6 (diff)
update to 1.6.1
switch to classmap autoloader
-rw-r--r--composer.json17
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt.spec30
2 files changed, 27 insertions, 20 deletions
diff --git a/composer.json b/composer.json
index bb2dee8..6a18348 100644
--- a/composer.json
+++ b/composer.json
@@ -30,18 +30,19 @@
"ext-posix": "*"
},
"require-dev": {
- "apigen/apigen": "^4.1.2",
- "bartlett/php-compatinfo": "^5.0.10 || ^5.0.12",
- "pdepend/pdepend": "^2.5.2",
- "phploc/phploc": "^2.1 || ^3.0 || ^4.0",
- "phpmd/phpmd": "^2.6.0",
- "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.1",
- "sebastian/phpcpd": "^2.0 || ^3.0 || ^4.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.2.0"
+ "pdepend/pdepend": "2.8.0",
+ "phploc/phploc": "7.0.2 || 6.0.2 || 5.0.0 || 4.0.1 || 3.0.1 || 2.1.5",
+ "phpmd/phpmd": "2.9.1",
+ "phpunit/phpunit": "9.5.0 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
+ "sebastian/phpcpd": "6.0.3 || 5.0.2 || 4.1.0 || 3.0.1 || 2.0.4",
+ "squizlabs/php_codesniffer": "3.5.8 || 2.9.2"
},
"autoload": {
"psr-4": {
"Com\\Tecnick\\Pdf\\Encrypt\\": "src"
}
+ },
+ "autoload-dev": {
+ "psr-4": { "Test\\": "test" }
}
}
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt.spec
index fd8615f..ad071da 100644
--- a/php-tecnickcom-tc-lib-pdf-encrypt.spec
+++ b/php-tecnickcom-tc-lib-pdf-encrypt.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 9b2ef81b4879e6f0e339ad0ffb1ee8d5e68f389f
+%global gh_commit d70022f5aeaba240a2f9f1828b78b1efc3a4ffd8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.5.10
+Version: 1.6.1
Release: 1%{?dist}
Summary: PHP library to encrypt data for PDF
@@ -32,13 +32,15 @@ BuildRequires: php-hash
BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-posix
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit7
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.5.0
%else
-%global phpunit %{_bindir}/phpunit
+%global phpunit %{_bindir}/phpunit8
+BuildRequires: phpunit8 >= 8.5.13
%endif
-BuildRequires: %{phpunit}
%endif
+BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
# "php": ">=5.4",
@@ -56,6 +58,7 @@ Requires: php-pcre
Requires: php-posix
# From phpcompatinfo report for version 1.5.0
# none
+Requires: php-composer(fedora/autoloader)
# Composer
Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
@@ -77,30 +80,29 @@ grep -q '^%{version}$' VERSION
%build
-# Empty build section, most likely nothing required.
+phpab --template fedora --output src/autoload.php src
%install
mkdir -p $(dirname %{buildroot}%{php_project})
cp -pr src %{buildroot}%{php_project}
-cp -p resources/autoload.php \
- %{buildroot}%{php_project}/autoload.php
%check
%if %{with_tests}
mkdir vendor
-cat <<EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
date_default_timezone_set("UTC");
require '%{buildroot}%{php_project}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('Test\\', dirname(__DIR__) . '/test');
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -121,6 +123,10 @@ exit $ret
%changelog
+* Mon Dec 21 2020 Remi Collet <remi@remirepo.net> - 1.6.1-1
+- update to 1.6.1
+- switch to classmap autoloader
+
* Fri Jan 3 2020 Remi Collet <remi@remirepo.net> - 1.5.10-1
- update to 1.5.10 (no change)