summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-22 09:16:48 +0100
committerRemi Collet <remi@php.net>2022-12-22 09:16:48 +0100
commit16e0b769b46a54d3b7de107bd56860a227075560 (patch)
treee205daae157217ed79965f9bf1fb85f41a03c494
parenta256ac780f4883adcc5c3d803fc4feab69afa205 (diff)
update to 1.6.14
-rw-r--r--composer.json8
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt.spec18
2 files changed, 12 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index ded0854..c6e67f3 100644
--- a/composer.json
+++ b/composer.json
@@ -30,12 +30,12 @@
"ext-posix": "*"
},
"require-dev": {
- "pdepend/pdepend": "2.10.2",
+ "pdepend/pdepend": "2.12.1",
"phploc/phploc": "7.0.2 || 6.0.2 || 5.0.0 || 4.0.1 || 3.0.1 || 2.1.5",
- "phpmd/phpmd": "2.11.1",
- "phpunit/phpunit": "9.5.11 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
+ "phpmd/phpmd": "2.13.0",
+ "phpunit/phpunit": "9.5.27 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
"sebastian/phpcpd": "6.0.3 || 5.0.2 || 4.1.0 || 3.0.1 || 2.0.4",
- "squizlabs/php_codesniffer": "3.6.2 || 2.9.2"
+ "squizlabs/php_codesniffer": "3.7.1 || 2.9.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt.spec
index 4169036..80f0cc1 100644
--- a/php-tecnickcom-tc-lib-pdf-encrypt.spec
+++ b/php-tecnickcom-tc-lib-pdf-encrypt.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 6c9f137c112607d8358f35939e8c495e9d56380a
+%global gh_commit 6ad8865c487f42b74cc217f0237c89e02c2da368
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,11 +15,11 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.6.10
+Version: 1.6.14
Release: 1%{?dist}
Summary: PHP library to encrypt data for PDF
-License: LGPLv3+
+License: LGPL-3.0-or-later
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
@@ -32,13 +32,8 @@ BuildRequires: php-hash
BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-posix
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.0
-%else
-%global phpunit %{_bindir}/phpunit8
-BuildRequires: phpunit8 >= 8.5.13
-%endif
+BuildRequires: phpunit9 >= 9.5.27
%endif
BuildRequires: php-fedora-autoloader-devel
@@ -103,7 +98,7 @@ VER=$(php -r 'echo (OPENSSL_VERSION_NUMBER>>28);')
if [ $VER -ge 3 ]; then
FILTER="--filter '^((?!(testEncryptPubThree|testEncryptPubNoP|testEncryptModZeroPub|testGetPdfEncryptionObjThreePub|testGetPdfEncryptionObjOnePub|testGetEncryptionData|testGetObjectKey|testEncryptStringEnabled|testEscapeDataStringEnabled|testGetPdfEncryptionObjOne|testGetPdfEncryptionObjZero)).)*$'"
fi
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} $FILTER --no-coverage --verbose || ret=1
@@ -127,6 +122,9 @@ exit $ret
%changelog
+* Thu Dec 22 2022 Remi Collet <remi@remirepo.net> - 1.6.14-1
+- update to 1.6.14
+
* Tue Jun 14 2022 Remi Collet <remi@remirepo.net> - 1.6.10-1
- update to 1.6.10 (no change)