summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-file.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-21 10:56:28 +0100
committerRemi Collet <remi@remirepo.net>2020-12-21 10:56:28 +0100
commitfc25759cd01d7d640500884a4def2fa77fcf4bae (patch)
treec6501df61b4b0030eb8c51733300af7b26256c83 /php-tecnickcom-tc-lib-file.spec
parentd8605769c48cce8ddfdd5dc006d6a5e55e78d826 (diff)
update to 1.7.2
switch to classmap autoloader
Diffstat (limited to 'php-tecnickcom-tc-lib-file.spec')
-rw-r--r--php-tecnickcom-tc-lib-file.spec30
1 files changed, 18 insertions, 12 deletions
diff --git a/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file.spec
index 2d00912..644e261 100644
--- a/php-tecnickcom-tc-lib-file.spec
+++ b/php-tecnickcom-tc-lib-file.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 4ea05098b69ef7f6098eeab9162ffa8fb033e4f3
+%global gh_commit 8da98e04e0962cb0ac3146e56a2a0ea3caa22288
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.6.14
+Version: 1.7.2
Release: 1%{?dist}
Summary: PHP library to read byte-level data from files
@@ -26,16 +26,18 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit7
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.5.0
%else
-%global phpunit %{_bindir}/phpunit
+%global phpunit %{_bindir}/phpunit8
+BuildRequires: phpunit8 >= 8.5.13
%endif
-BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
BuildRequires: php-curl
BuildRequires: php-pcre
%endif
+BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
# "php": ">=5.4",
@@ -46,6 +48,7 @@ Requires: php-curl
Requires: php-pcre
# From phpcompatinfo report for version 1.6.4
# none
+Requires: php-composer(fedora/autoloader)
# Composer
Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
@@ -67,31 +70,30 @@ grep -q '^%{version}$' VERSION
%build
-# Empty build section, most likely nothing required.
+phpab --template fedora --output src/autoload.php src
%install
mkdir -p $(dirname %{buildroot}%{php_project})
cp -pr src %{buildroot}%{php_project}
-cp -p resources/autoload.php \
- %{buildroot}%{php_project}/autoload.php
%check
%if %{with_tests}
mkdir vendor
-cat <<EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require '%{buildroot}%{php_project}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('Test\\', dirname(__DIR__) . '/test');
EOF
sed -i 's:src:File:g' -i test/DirTest.php
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -111,6 +113,10 @@ exit $ret
%changelog
+* Mon Dec 21 2020 Remi Collet <remi@remirepo.net> - 1.7.2-1
+- update to 1.7.2
+- switch to classmap autoloader
+
* Fri Jan 3 2020 Remi Collet <remi@remirepo.net> - 1.6.14-1
- update to 1.6.14 (no change)