summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-14 07:22:42 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-14 07:22:42 +0200
commitf2138cd099378d71d4a28c60c1784efe3d13a935 (patch)
tree0fd59625da434ddc9abce656896316f950f9b844
parentf274a5d9c810271106a8d940f0286564de317bd6 (diff)
php-tecnickcom-tc-lib-file: 1.6.0
-rw-r--r--composer.json33
-rw-r--r--php-tecnickcom-tc-lib-file.spec7
2 files changed, 38 insertions, 2 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..a81789f
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,33 @@
+{
+ "name": "tecnickcom/tc-lib-file",
+ "description": "PHP library to read byte-level data from files",
+ "type": "library",
+ "homepage": "http://www.tecnick.com",
+ "license": "LGPL-3.0",
+ "keywords": ["tc-lib-file", "file", "byte", "bit", "read", "short", "long", "double"],
+ "authors": [
+ {
+ "name": "Nicola Asuni",
+ "email": "info@tecnick.com",
+ "role": "lead"
+ }
+ ],
+ "require": {
+ "php": ">=5.4"
+ },
+ "require-dev": {
+ "apigen/apigen" : "^4.1.2",
+ "bartlett/php-compatinfo" : "^5.0.0",
+ "pdepend/pdepend" : "^2.2.2",
+ "phploc/phploc" : "^2.1.5|^3.0.0",
+ "phpmd/phpmd" : "^2.3.2",
+ "phpunit/phpunit": "4.8.19|^5.0.0",
+ "sebastian/phpcpd" : "^2.0.2",
+ "squizlabs/php_codesniffer": "^2.5.0|^3.0.0"
+ },
+ "autoload": {
+ "psr-4":{
+ "Com\\Tecnick\\File\\": "src"
+ }
+ }
+}
diff --git a/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file.spec
index 797f0d9..d6d314c 100644
--- a/php-tecnickcom-tc-lib-file.spec
+++ b/php-tecnickcom-tc-lib-file.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit ef5915f15b78738a833aebbd720a2c1323cbfe4d
+%global gh_commit d07655331e9044df1b80b63e66fb574b1924f902
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.5.0
+Version: 1.6.0
Release: 1%{?dist}
Summary: PHP library to read byte-level data from files
@@ -108,6 +108,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 1.6.0-1
+- update to 1.6.0 (no change)
+
* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 1.5.0-1
- update to 1.5.0