summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-15 08:23:38 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-15 08:23:38 +0100
commitd72a94db323fa4ebfa59e4610a392410e526715c (patch)
tree0761174db5e30eaa98690f0fa5cdcf8657d99e3d
php-tecnickcom-tc-lib-file: 1.2.0, new package
-rw-r--r--Makefile4
-rw-r--r--php-tecnickcom-tc-lib-file.spec112
2 files changed, 116 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file.spec
new file mode 100644
index 0000000..cc9b4f8
--- /dev/null
+++ b/php-tecnickcom-tc-lib-file.spec
@@ -0,0 +1,112 @@
+# remirepo/fedora spec file for php-tecnickcom-tc-lib-file
+#
+# Copyright (c) 2015-2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 310d6897877cbf15724e2d31c57c745a5eb0a2da
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global c_vendor tecnickcom
+%global gh_owner tecnickcom
+%global gh_project tc-lib-file
+%global php_project %{_datadir}/php/Com/Tecnick/File
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.2.0
+Release: 1%{?dist}
+Summary: PHP library to read byte-level data from files
+
+Group: Development/Libraries
+License: LGPLv3+
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: php(language) >= 5.4
+BuildRequires: php-curl
+BuildRequires: php-pcre
+%endif
+
+# From composer.json, "require": {
+# "php": ">=5.4"
+Requires: php(language) >= 5.4
+# From phpcompatinfo report for version 1.2.0
+Requires: php-curl
+Requires: php-pcre
+
+# Composer
+Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
+# Upstream package name
+Provides: php-%{gh_project} = %{version}
+
+
+%description
+This library includes utility classes to read byte-level data.
+
+The initial source code has been extracted from TCPDF (http://www.tcpdf.org).
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+: Sanity check
+grep -q '^%{version}$' VERSION
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p $(dirname %{buildroot}%{php_project})
+cp -pr src %{buildroot}%{php_project}
+cp -p resources/autoload.php \
+ %{buildroot}%{php_project}/autoload.php
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat <<EOF | tee vendor/autoload.php
+<?php
+require '%{buildroot}%{php_project}/autoload.php';
+EOF
+
+sed -i 's:src:File:g' -i test/DirTest.php
+
+%{_bindir}/phpunit --verbose
+
+if which php70; then
+ php70 %{_bindir}/phpunit --verbose
+fi
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc README.md
+%dir %{_datadir}/php/Com
+%dir %{_datadir}/php/Com/Tecnick
+%{php_project}
+
+
+%changelog
+* Fri Jan 15 2016 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
+- initial package, version 1.2.0 \ No newline at end of file