summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-22 09:18:38 +0100
committerRemi Collet <remi@php.net>2022-12-22 09:18:38 +0100
commitd5468be190bb0fce3f309c450e77b68571176dd5 (patch)
tree058e963503a1b3f91e233bfbf29d0c1c413cc1f3
parentbbcda98b5521c7c90b7e9020ce625d7647749cc0 (diff)
update to 1.7.18 (no change)
-rw-r--r--composer.json8
-rw-r--r--php-tecnickcom-tc-lib-file.spec18
2 files changed, 12 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 4e14911..2a2d84c 100644
--- a/composer.json
+++ b/composer.json
@@ -27,12 +27,12 @@
"ext-pcre": "*"
},
"require-dev": {
- "pdepend/pdepend": "2.10.2",
+ "pdepend/pdepend": "2.12.1",
"phploc/phploc": "7.0.2 || 6.0.2 || 5.0.0 || 4.0.1 || 3.0.1 || 2.1.5",
- "phpmd/phpmd": "2.11.1",
- "phpunit/phpunit": "9.5.11 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
+ "phpmd/phpmd": "2.13.0",
+ "phpunit/phpunit": "9.5.27 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
"sebastian/phpcpd": "6.0.3 || 5.0.2 || 4.1.0 || 3.0.1 || 2.0.4",
- "squizlabs/php_codesniffer": "3.6.2 || 2.9.2"
+ "squizlabs/php_codesniffer": "3.7.1 || 2.9.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file.spec
index a60c6b2..f4bfea7 100644
--- a/php-tecnickcom-tc-lib-file.spec
+++ b/php-tecnickcom-tc-lib-file.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit aa03fcc70873a620cc2ebcd351bbb005830c338d
+%global gh_commit dbee80f60c49d1196ae7ccd3c08e64bec57fc1ea
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,24 +15,19 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.7.14
+Version: 1.7.18
Release: 1%{?dist}
Summary: PHP library to read byte-level data from files
-License: LGPLv3+
+License: LGPL-3.0-or-later
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
BuildArch: noarch
%if %{with_tests}
# For tests
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.0
-%else
-%global phpunit %{_bindir}/phpunit8
-BuildRequires: phpunit8 >= 8.5.13
-%endif
+BuildRequires: phpunit9 >= 9.5.27
BuildRequires: php(language) >= 5.4
BuildRequires: php-curl
BuildRequires: php-pcre
@@ -90,7 +85,7 @@ EOF
sed -i 's:src:File:g' -i test/DirTest.php
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
@@ -113,6 +108,9 @@ exit $ret
%changelog
+* Thu Dec 22 2022 Remi Collet <remi@remirepo.net> - 1.7.18-1
+- update to 1.7.18 (no change)
+
* Tue Jun 14 2022 Remi Collet <remi@remirepo.net> - 1.7.14-1
- update to 1.7.14 (no change)