summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-03 09:16:45 +0100
committerRemi Collet <remi@php.net>2022-01-03 09:16:45 +0100
commit8ebd6ad569a0f5f1ba64876e3ab41fabb84ae209 (patch)
tree1bbb77556c72a1702fdad5c07a6f54edff411f47
parentf611b181fed572f6e90fda2a4ca838476d77b7f4 (diff)
update to 1.7.11
-rw-r--r--composer.json8
-rw-r--r--php-tecnickcom-tc-lib-file.spec11
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 2ed0174..4e14911 100644
--- a/composer.json
+++ b/composer.json
@@ -27,12 +27,12 @@
"ext-pcre": "*"
},
"require-dev": {
- "pdepend/pdepend": "2.8.0",
+ "pdepend/pdepend": "2.10.2",
"phploc/phploc": "7.0.2 || 6.0.2 || 5.0.0 || 4.0.1 || 3.0.1 || 2.1.5",
- "phpmd/phpmd": "2.9.1",
- "phpunit/phpunit": "9.5.0 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
+ "phpmd/phpmd": "2.11.1",
+ "phpunit/phpunit": "9.5.11 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
"sebastian/phpcpd": "6.0.3 || 5.0.2 || 4.1.0 || 3.0.1 || 2.0.4",
- "squizlabs/php_codesniffer": "3.5.8 || 2.9.2"
+ "squizlabs/php_codesniffer": "3.6.2 || 2.9.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file.spec
index 34b2ad9..5aa6bf7 100644
--- a/php-tecnickcom-tc-lib-file.spec
+++ b/php-tecnickcom-tc-lib-file.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-file
#
-# Copyright (c) 2016-2021 Remi Collet
+# Copyright (c) 2016-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 078dddb08b4364abd700457ab031e9886016641a
+%global gh_commit 134986dce50b21edc8c51fdc36edfb9b56091713
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.7.7
+Version: 1.7.11
Release: 1%{?dist}
Summary: PHP library to read byte-level data from files
@@ -90,7 +90,7 @@ EOF
sed -i 's:src:File:g' -i test/DirTest.php
ret=0
-for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
@@ -113,6 +113,9 @@ exit $ret
%changelog
+* Mon Jan 3 2022 Remi Collet <remi@remirepo.net> - 1.7.11-1
+- update to 1.7.11
+
* Mon Feb 8 2021 Remi Collet <remi@remirepo.net> - 1.7.7-1
- update to 1.7.7 (no change)