summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-22 13:42:18 +0100
committerRemi Collet <remi@php.net>2023-11-22 13:42:18 +0100
commit2b2f3eeb9054cff3c7ddab50871b26c5902610d3 (patch)
treec08c367c5ae59a4cf316020c2289eeedcc766954
parentd40fd3cbd22209d54711d6a15d48378d2350407d (diff)
update to 2.0.7
raise dependency on PHP 8
-rw-r--r--composer.json6
-rw-r--r--php-tecnickcom-tc-lib-file.spec16
2 files changed, 13 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 99eb6ce..cc1a135 100644
--- a/composer.json
+++ b/composer.json
@@ -22,15 +22,15 @@
}
],
"require": {
- "php": ">=5.4",
+ "php": ">=8.0",
"ext-curl": "*",
"ext-pcre": "*"
},
"require-dev": {
"pdepend/pdepend": "2.13.0",
"phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "10.1.2 || 9.6.7 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
- "squizlabs/php_codesniffer": "3.7.2 || 2.9.2"
+ "phpunit/phpunit": "10.1.2 || 9.6.13",
+ "squizlabs/php_codesniffer": "3.7.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file.spec
index 1ceb91c..8d1f137 100644
--- a/php-tecnickcom-tc-lib-file.spec
+++ b/php-tecnickcom-tc-lib-file.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 06c94a9396343863d27048e7c7695f67d1566096
+%global gh_commit f1eef59ace3f85dfca874a2a469ce12bb5e958e7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.7.39
+Version: 2.0.7
Release: 1%{?dist}
Summary: PHP library to read byte-level data from files
@@ -29,13 +29,13 @@ BuildArch: noarch
# remirepo:1
%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
%global phpunit %{_bindir}/phpunit10
-BuildRequires: phpunit10
+BuildRequires: phpunit10 >= 10.1.2
# remirepo:4
%else
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.27
+BuildRequires: phpunit9 >= 9.6.13
%endif
-BuildRequires: php(language) >= 5.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-curl
BuildRequires: php-pcre
%endif
@@ -45,7 +45,7 @@ BuildRequires: php-fedora-autoloader-devel
# "php": ">=5.4",
# "ext-curl": "*",
# "ext-pcre": "*"
-Requires: php(language) >= 5.4
+Requires: php(language) >= 8.0
Requires: php-curl
Requires: php-pcre
# From phpcompatinfo report for version 1.6.4
@@ -118,6 +118,10 @@ exit $ret
%changelog
+* Wed Nov 22 2023 Remi Collet <remi@remirepo.net> - 2.0.7-1
+- update to 2.0.7
+- raise dependency on PHP 8
+
* Mon Oct 23 2023 Remi Collet <remi@remirepo.net> - 1.7.39-1
- update to 1.7.39 (no change)