summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-color.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-21 10:31:32 +0100
committerRemi Collet <remi@remirepo.net>2020-12-21 10:31:32 +0100
commitc3a9ff63963732ee3cf4c20342144283d2b07650 (patch)
treee240e6189cdb7d5de265005a577fd34ebfa132e9 /php-tecnickcom-tc-lib-color.spec
parent214cda5b0e842b6252f3462ff8311a6f70ea9385 (diff)
update to 1.14.1
switch to classmap autoloader
Diffstat (limited to 'php-tecnickcom-tc-lib-color.spec')
-rw-r--r--php-tecnickcom-tc-lib-color.spec27
1 files changed, 16 insertions, 11 deletions
diff --git a/php-tecnickcom-tc-lib-color.spec b/php-tecnickcom-tc-lib-color.spec
index 1407f78..ac78fa5 100644
--- a/php-tecnickcom-tc-lib-color.spec
+++ b/php-tecnickcom-tc-lib-color.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 2f4860cbac4d58c210b6bec4c5806906278962c1
+%global gh_commit 00c6c6e95df12448ecd758b64a70f2b2b2fe2367
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.12.15
+Version: 1.14.1
Release: 1%{?dist}
Summary: PHP library to manipulate various color representations
@@ -26,15 +26,16 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit7
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
%else
-%global phpunit %{_bindir}/phpunit
+%global phpunit %{_bindir}/phpunit8
%endif
BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.3
-Requires: php-pcre
+BuildRequires: php-pcre
%endif
+BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
# "php": ">=5.3",
@@ -43,6 +44,7 @@ Requires: php(language) >= 5.3
Requires: php-pcre
# From phpcompatinfo report for version 1.12.4
# none
+Requires: php-composer(fedora/autoloader)
# Composer
Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
@@ -70,14 +72,12 @@ sed -e 's:^require:////require:' \
%build
-# Empty build section, most likely nothing required.
+phpab --template fedora --output src/autoload.php src
%install
mkdir -p $(dirname %{buildroot}%{php_project})
cp -pr src %{buildroot}%{php_project}
-cp -p resources/autoload.php \
- %{buildroot}%{php_project}/autoload.php
%check
@@ -86,13 +86,14 @@ mkdir vendor
cat <<EOF | tee vendor/autoload.php
<?php
require '%{buildroot}%{php_project}/autoload.php';
+require dirname(__DIR__) . '/test/TestUtil.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -112,6 +113,10 @@ exit $ret
%changelog
+* Mon Dec 21 2020 Remi Collet <remi@remirepo.net> - 1.14.1-1
+- update to 1.14.1
+- switch to classmap autoloader
+
* Fri Jan 3 2020 Remi Collet <remi@remirepo.net> - 1.12.15-1
- update to 1.12.15 (no change)