summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-color.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-07-01 16:15:27 +0200
committerRemi Collet <fedora@famillecollet.com>2015-07-01 16:15:27 +0200
commitad016242fbe90d543f71feff54d68a02cec464f4 (patch)
treec903d621c80cea8f9b3ce00f6875a2d93b07eeac /php-tecnickcom-tc-lib-color.spec
php-tecnickcom-tc-lib-color: 1.4.5 - New package
Diffstat (limited to 'php-tecnickcom-tc-lib-color.spec')
-rw-r--r--php-tecnickcom-tc-lib-color.spec111
1 files changed, 111 insertions, 0 deletions
diff --git a/php-tecnickcom-tc-lib-color.spec b/php-tecnickcom-tc-lib-color.spec
new file mode 100644
index 0000000..9e47c59
--- /dev/null
+++ b/php-tecnickcom-tc-lib-color.spec
@@ -0,0 +1,111 @@
+# remirepo/fedora spec file for php-tecnickcom-tc-lib-color
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 681df858ebf5e07bb014732094bc2b221b1626c2
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global c_vendor tecnick.com
+%global gh_owner tecnickcom
+%global gh_project tc-lib-color
+%global php_home %{_datadir}/php/Com/Tecnick
+%global php_project %{php_home}/Color
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.4.5
+Release: 1%{?dist}
+Summary: PHP library to manipulate various color representations
+
+Group: Development/Libraries
+License: LGPLv3+
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: %{_bindir}/phpunit
+BuildRequires: php(language) >= 5.3.3
+Requires: php-pcre
+%endif
+
+# From composer.json, "require": {
+# "php": ">=5.3.3"
+Requires: php(language) >= 5.3.3
+# From phpcompatinfo report for version 1.4.5
+Requires: php-pcre
+
+# Composer
+Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
+# Upstream package name
+Provides: php-%{gh_project} = %{version}
+
+
+%description
+Provides tc-lib-color: PHP library to manipulate various color
+representations (GRAY, RGB, HSL, CMYK) and parse Web colors.
+
+The initial source code has been extracted from TCPDF (http://www.tcpdf.org).
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+: Sanity check
+grep -q '^%{version}$' VERSION
+
+: Fix the examples
+sed -e 's:^require:////require:' \
+ -e 's:^//require:require:' \
+ -i example/*php
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{php_home}
+cp -pr src %{buildroot}%{php_project}
+cp -p resources/autoload.php \
+ %{buildroot}%{php_project}/autoload.php
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat <<EOF | tee vendor/autoload.php
+<?php
+require '%{buildroot}%{php_project}/autoload.php';
+EOF
+
+%{_bindir}/phpunit --verbose
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.TXT
+%doc composer.json
+%doc README.md example
+%dir %{_datadir}/php/Com
+%dir %{_datadir}/php/Com/Tecnick
+%{php_project}
+
+
+%changelog
+* Wed Jul 1 2015 Remi Collet <remi@fedoraproject.org> - 1.4.5-1
+- initial package, version 1.4.5 \ No newline at end of file