summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-06 07:29:09 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-06 07:29:09 +0100
commitdcc877d1c6276ea9fa163d9ec480bbe01a6be7ed (patch)
tree048b4e6946a3dd98f0662f80d02dbfffd48e4e27
parent3eadf3a03a1c27a2dc5f72401b0477e603d3250a (diff)
php-tecnickcom-tc-lib-color: 1.12.4
-rw-r--r--composer.json3
-rw-r--r--php-tecnickcom-tc-lib-color.spec32
2 files changed, 16 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index 1e5f459..aa77c42 100644
--- a/composer.json
+++ b/composer.json
@@ -13,7 +13,8 @@
}
],
"require": {
- "php": ">=5.4"
+ "php": ">=5.4",
+ "ext-pcre": "*"
},
"require-dev": {
"apigen/apigen" : "^4.1.2",
diff --git a/php-tecnickcom-tc-lib-color.spec b/php-tecnickcom-tc-lib-color.spec
index 5c66feb..6b6a618 100644
--- a/php-tecnickcom-tc-lib-color.spec
+++ b/php-tecnickcom-tc-lib-color.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit d86d7ca6153ce9fcde7ae4043567aaf4a184b347
+%global gh_commit ba1c4a9debecb0da843c13861b602a23127aeabf
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.12.1
+Version: 1.12.4
Release: 1%{?dist}
Summary: PHP library to manipulate various color representations
@@ -34,10 +34,12 @@ Requires: php-pcre
%endif
# From composer.json, "require": {
-# "php": ">=5.4"
+# "php": ">=5.4",
+# "ext-pcre": "*"
Requires: php(language) >= 5.4
-# From phpcompatinfo report for version 1.4.5
Requires: php-pcre
+# From phpcompatinfo report for version 1.12.4
+# none
# Composer
Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
@@ -84,21 +86,12 @@ cat <<EOF | tee vendor/autoload.php
require '%{buildroot}%{php_project}/autoload.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php56 php70 php71 php; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
@@ -121,6 +114,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Feb 6 2017 Remi Collet <remi@fedoraproject.org> - 1.12.4-1
+- update to 1.12.4 (no change)
+
* Fri Sep 2 2016 Remi Collet <remi@fedoraproject.org> - 1.12.1-1
- update to 1.12.1