summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-10-23 13:46:03 +0200
committerRemi Collet <remi@php.net>2023-10-23 13:46:03 +0200
commitcdd551455631615e6562c8f649715e564712a070 (patch)
tree5f05f789b368f1ae0869a6d1a7467007aa375335
parent63a60413814a212812907b9bb8f18355a5e2c63e (diff)
update to 1.14.39 (no change)
-rw-r--r--php-tecnickcom-tc-lib-color.spec22
1 files changed, 17 insertions, 5 deletions
diff --git a/php-tecnickcom-tc-lib-color.spec b/php-tecnickcom-tc-lib-color.spec
index 3d0d097..c0e6817 100644
--- a/php-tecnickcom-tc-lib-color.spec
+++ b/php-tecnickcom-tc-lib-color.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 2d7b7e421dba1836d23912723d83adebc53f0ef6
+%global gh_commit f7a414e7ddbdcd98105506ca1eecc68d4820fb89
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.14.37
+Version: 1.14.39
Release: 1%{?dist}
Summary: PHP library to manipulate various color representations
@@ -26,8 +26,15 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
+# remirepo:1
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
+%global phpunit %{_bindir}/phpunit10
+BuildRequires: phpunit10
+# remirepo:4
+%else
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.5.27
+%endif
BuildRequires: php(language) >= 5.3
BuildRequires: php-pcre
%endif
@@ -86,11 +93,12 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php80 %{phpunit}" php81 php82; do
+for cmdarg in php "php80 %{_bindir}/phpunit9" php81 php82 php83; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit10} --migrate-configuration || :
- $1 ${2:-%{_bindir}/phpunit10} --no-coverage || ret=1
+ cp phpunit.xml.dist phpunit.xml
+ $1 ${2:-%{phpunit}} --migrate-configuration || :
+ $1 ${2:-%{phpunit}} --no-coverage || ret=1
fi
done
exit $ret
@@ -100,6 +108,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -110,6 +119,9 @@ exit $ret
%changelog
+* Mon Oct 23 2023 Remi Collet <remi@remirepo.net> - 1.14.39-1
+- update to 1.14.39 (no change)
+
* Thu Oct 12 2023 Remi Collet <remi@remirepo.net> - 1.14.37-1
- update to 1.14.37