summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-15 06:47:00 +0200
committerRemi Collet <remi@remirepo.net>2018-05-15 06:47:00 +0200
commita028319b918994fe122514ab12c3eed172c6ce9d (patch)
tree1374624c5ce0b2af6b29b6b99888c3c65d2646af
parent8363f924fdf638f5f887158306f72902766e20ab (diff)
update to 1.12.11 (no change)
-rw-r--r--composer.json6
-rw-r--r--php-tecnickcom-tc-lib-color.spec15
2 files changed, 12 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index bf1f92a..233b32c 100644
--- a/composer.json
+++ b/composer.json
@@ -26,12 +26,12 @@
}
],
"require": {
- "php": ">=5.4",
+ "php": ">=5.3",
"ext-pcre": "*"
},
"require-dev": {
- "apigen/apigen": "^4.1.2",
- "bartlett/php-compatinfo": "^5.0.10 || ^5.0.12",
+ "apigen/apigen": "^2.8.1 || ^4.1.2",
+ "bartlett/php-compatinfo": "^4.5.2 || ^5.0.10 || ^5.0.12",
"pdepend/pdepend": "^2.5.2",
"phploc/phploc": "^2.1 || ^3.0 || ^4.0",
"phpmd/phpmd": "^2.6.0",
diff --git a/php-tecnickcom-tc-lib-color.spec b/php-tecnickcom-tc-lib-color.spec
index a0d1923..f031421 100644
--- a/php-tecnickcom-tc-lib-color.spec
+++ b/php-tecnickcom-tc-lib-color.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 6b22174439020d28554cf7b8d2b6191faf972516
+%global gh_commit 668548964e3a16cb87b681a784f6e74070c6f668
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.12.10
+Version: 1.12.11
Release: 1%{?dist}
Summary: PHP library to manipulate various color representations
@@ -27,20 +27,20 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-%if 0%{?fedora} >= 28
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit7
%else
%global phpunit %{_bindir}/phpunit
%endif
BuildRequires: %{phpunit}
-BuildRequires: php(language) >= 5.4
+BuildRequires: php(language) >= 5.3
Requires: php-pcre
%endif
# From composer.json, "require": {
-# "php": ">=5.4",
+# "php": ">=5.3",
# "ext-pcre": "*"
-Requires: php(language) >= 5.4
+Requires: php(language) >= 5.3
Requires: php-pcre
# From phpcompatinfo report for version 1.12.4
# none
@@ -113,6 +113,9 @@ exit $ret
%changelog
+* Tue May 15 2018 Remi Collet <remi@remirepo.net> - 1.12.11-1
+- update to 1.12.11 (no change)
+
* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 1.12.10-1
- update to 1.12.10 (no change)
- switch to phpunit7