summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-22 13:28:55 +0100
committerRemi Collet <remi@php.net>2023-11-22 13:28:55 +0100
commit4f1d9f0d88289883c5d68b072ed3c5bf190d655d (patch)
treea4fe86f211e2748d56fe898d40d0a57f41897c20
parent818f75eb8ce9b593dd39a1fb278961a1a5f59c44 (diff)
update to 2.0.4
raise dependency on PHP 8
-rw-r--r--composer.json6
-rw-r--r--php-tecnickcom-tc-lib-color.spec18
2 files changed, 14 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 40b58dc..a6b2567 100644
--- a/composer.json
+++ b/composer.json
@@ -26,14 +26,14 @@
}
],
"require": {
- "php": ">=5.3",
+ "php": ">=8.0",
"ext-pcre": "*"
},
"require-dev": {
"pdepend/pdepend": "2.13.0",
"phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "10.1.2 || 9.6.7 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
- "squizlabs/php_codesniffer": "3.7.2 || 2.9.2"
+ "phpunit/phpunit": "10.1.2 || 9.6.13",
+ "squizlabs/php_codesniffer": "3.7.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-color.spec b/php-tecnickcom-tc-lib-color.spec
index a200688..d6b3498 100644
--- a/php-tecnickcom-tc-lib-color.spec
+++ b/php-tecnickcom-tc-lib-color.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit f7a414e7ddbdcd98105506ca1eecc68d4820fb89
+%global gh_commit e4cd5d01209ca95c4795907bec3565013dcf3224
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.14.39
+Version: 2.0.4
Release: 1%{?dist}
Summary: PHP library to manipulate various color representations
@@ -29,21 +29,21 @@ BuildArch: noarch
# remirepo:1
%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
%global phpunit %{_bindir}/phpunit10
-BuildRequires: phpunit10
+BuildRequires: phpunit10 >= 10.1.2
# remirepo:4
%else
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.27
+BuildRequires: phpunit9 >= 9.6.13
%endif
-BuildRequires: php(language) >= 5.3
+BuildRequires: php(language) >= 8.0
BuildRequires: php-pcre
%endif
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=5.3",
+# "php": ">=8.0",
# "ext-pcre": "*"
-Requires: php(language) >= 5.3
+Requires: php(language) >= 8.0
Requires: php-pcre
# From phpcompatinfo report for version 1.12.4
# none
@@ -119,6 +119,10 @@ exit $ret
%changelog
+* Wed Nov 22 2023 Remi Collet <remi@remirepo.net> - 2.0.4-1
+- update to 2.0.4
+- raise dependency on PHP 8
+
* Mon Oct 23 2023 Remi Collet <remi@remirepo.net> - 1.14.39-1
- update to 1.14.39 (no change)