summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-barcode.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-tecnickcom-tc-lib-barcode.spec')
-rw-r--r--php-tecnickcom-tc-lib-barcode.spec14
1 files changed, 9 insertions, 5 deletions
diff --git a/php-tecnickcom-tc-lib-barcode.spec b/php-tecnickcom-tc-lib-barcode.spec
index 1b39260..6e31172 100644
--- a/php-tecnickcom-tc-lib-barcode.spec
+++ b/php-tecnickcom-tc-lib-barcode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 72452e2ed945a5856e6ed583b0bcad11148f9389
+%global gh_commit 2dc7d0d1087dda4961bd4af03a6575a510146f3e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.15.8
+Version: 1.15.10
Release: 1%{?dist}
Summary: PHP library to generate linear and bidimensional barcodes
@@ -27,7 +27,7 @@ BuildArch: noarch
%if %{with_tests}
# For tests
%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit6
+%global phpunit %{_bindir}/phpunit7
%else
%global phpunit %{_bindir}/phpunit
%endif
@@ -112,10 +112,10 @@ require __DIR__ . '/../test/TestStrings.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -133,6 +133,10 @@ exit $ret
%changelog
+* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 1.15.10-1
+- update to 1.15.10 (no change)
+- switch to phpunit7
+
* Sat Apr 21 2018 Remi Collet <remi@remirepo.net> - 1.15.8-1
- update to 1.15.8