summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-barcode.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-tecnickcom-tc-lib-barcode.spec')
-rw-r--r--php-tecnickcom-tc-lib-barcode.spec27
1 files changed, 21 insertions, 6 deletions
diff --git a/php-tecnickcom-tc-lib-barcode.spec b/php-tecnickcom-tc-lib-barcode.spec
index 10c13f3..4c346ca 100644
--- a/php-tecnickcom-tc-lib-barcode.spec
+++ b/php-tecnickcom-tc-lib-barcode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit b74f197e80e85707c0db2cc6f0fc57fb5e80e331
+%global gh_commit 2be245d0bec30d1d03a445c34dba16f4f2a36991
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%bcond_without tests
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.17.38
+Version: 1.18.2
Release: 1%{?dist}
Summary: PHP library to generate linear and bidimensional barcodes
@@ -26,11 +26,20 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with tests}
# For tests
+# remirepo:1
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
+%global phpunit %{_bindir}/phpunit10
+BuildRequires: phpunit10
+# remirepo:4
+%else
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.5.27
-BuildRequires: php(language) >= 5.4
+%endif
+BuildRequires: php(language) >= 5.6
+# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.14 with php-composer(%{c_vendor}/tc-lib-color) < 2)
+# remirepo:4
%else
BuildRequires: php-%{c_vendor}-tc-lib-color < 2
BuildRequires: php-%{c_vendor}-tc-lib-color >= 1.14
@@ -46,20 +55,22 @@ BuildRequires: php-pecl-imagick
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=5.4"
+# "php": ">=5.6"
# "ext-bcmath": "*",
# "ext-date": "*",
# "ext-gd": "*",
# "ext-pcre": "*",
# "tecnickcom/tc-lib-color": "^1.14"
-Requires: php(language) >= 5.4
+Requires: php(language) >= 5.6
Requires: php-bcmath
Requires: php-ctype
Requires: php-date
Requires: php-gd
Requires: php-pcre
+# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.14 with php-composer(%{c_vendor}/tc-lib-color) < 2)
+# remirepo:4
%else
Requires: php-%{c_vendor}-tc-lib-color < 2
Requires: php-%{c_vendor}-tc-lib-color >= 1.14
@@ -123,7 +134,7 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php80 %{phpunit}" php81 php82; do
+for cmdarg in "php %{phpunit}" "php80 %{_bindir}/phpunit9" php81 php82 php83; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit10} --migrate-configuration || :
@@ -138,6 +149,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -146,6 +158,9 @@ exit $ret
%changelog
+* Mon Oct 23 2023 Remi Collet <remi@remirepo.net> - 1.18.2-1
+- update to 1.18.2
+
* Thu Oct 12 2023 Remi Collet <remi@remirepo.net> - 1.17.38-1
- update to 1.17.38