summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--51.patch31
-rw-r--r--composer.json2
-rw-r--r--php-tecnickcom-tc-lib-barcode.spec15
3 files changed, 9 insertions, 39 deletions
diff --git a/51.patch b/51.patch
deleted file mode 100644
index 6b87e67..0000000
--- a/51.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 7c1c7693ca684c778d59a35accec6622f9879877 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 2 Jan 2020 14:10:52 +0100
-Subject: [PATCH] skip non hexa char. for 7.4
-
----
- src/Type/Linear/MsiCheck.php | 11 +++++++----
- 1 file changed, 7 insertions(+), 4 deletions(-)
-
-diff --git a/src/Type/Linear/MsiCheck.php b/src/Type/Linear/MsiCheck.php
-index f658f90..9725fa9 100644
---- a/src/Type/Linear/MsiCheck.php
-+++ b/src/Type/Linear/MsiCheck.php
-@@ -77,10 +77,13 @@ protected function getChecksum($code)
- $pix = 2;
- $check = 0;
- for ($pos = ($clen - 1); $pos >= 0; --$pos) {
-- $check += (hexdec($code[$pos]) * $pix);
-- ++$pix;
-- if ($pix > 7) {
-- $pix = 2;
-+ $t = $code[$pos];
-+ if ($t >= "0" && $t <= "9" || $t >= "a" && $t <= "f" || $t >= "A" && $t <= "F") {
-+ $check += (hexdec($t) * $pix);
-+ ++$pix;
-+ if ($pix > 7) {
-+ $pix = 2;
-+ }
- }
- }
- $check %= 11;
diff --git a/composer.json b/composer.json
index 06a063b..0c62d81 100644
--- a/composer.json
+++ b/composer.json
@@ -54,7 +54,7 @@
"ext-date": "*",
"ext-gd": "*",
"ext-pcre": "*",
- "tecnickcom/tc-lib-color": "^1.12.13"
+ "tecnickcom/tc-lib-color": "^1.12.15"
},
"require-dev": {
"apigen/apigen": "^2.8.1 || ^4.1.2",
diff --git a/php-tecnickcom-tc-lib-barcode.spec b/php-tecnickcom-tc-lib-barcode.spec
index 646099a..7e201db 100644
--- a/php-tecnickcom-tc-lib-barcode.spec
+++ b/php-tecnickcom-tc-lib-barcode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 853b29c4369b368e2c890084184bc4420b7707b8
+%global gh_commit dd8de5620ec436d61cc8535e11f2879146ebc16b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.15.18
+Version: 1.15.20
Release: 1%{?dist}
Summary: PHP library to generate linear and bidimensional barcodes
@@ -23,8 +23,6 @@ License: LGPLv3+
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
-Patch0: https://patch-diff.githubusercontent.com/raw/tecnickcom/tc-lib-barcode/pull/51.patch
-
BuildArch: noarch
%if %{with_tests}
# For tests
@@ -42,6 +40,7 @@ BuildRequires: php-composer(%{c_vendor}/tc-lib-color) < 2
BuildRequires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.13
%endif
BuildRequires: php-bcmath
+BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-gd
BuildRequires: php-pcre
@@ -55,9 +54,10 @@ BuildRequires: php-pecl-imagick
# "ext-date": "*",
# "ext-gd": "*",
# "ext-pcre": "*",
-# "tecnickcom/tc-lib-color": "^1.12.13"
+# "tecnickcom/tc-lib-color": "^1.12.15"
Requires: php(language) >= 5.3
Requires: php-bcmath
+Requires: php-ctype
Requires: php-date
Requires: php-gd
Requires: php-pcre
@@ -92,8 +92,6 @@ Optional dependency: php-pecl-imagick
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1 -b .pr51
-
: Sanity check
grep -q '^%{version}$' VERSION
@@ -146,6 +144,9 @@ exit $ret
%changelog
+* Fri Jan 3 2020 Remi Collet <remi@remirepo.net> - 1.15.20-1
+- update to 1.15.20
+
* Thu Jan 2 2020 Remi Collet <remi@remirepo.net> - 1.15.18-1
- update to 1.15.18
- add patch for 7.4 from