summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-14 07:50:04 +0200
committerRemi Collet <remi@remirepo.net>2020-07-14 07:50:04 +0200
commite57907e8d3eead74824b9fc0a672ac0a6a5588c0 (patch)
tree3fd3db6ed71425018fddc1cf9004eb8f0d1d9494
parent793e389f4303a6669860ec2d8996f0c122e39b55 (diff)
update to 1.16.1
-rw-r--r--composer.json2
-rw-r--r--php-tecnickcom-tc-lib-barcode.spec25
2 files changed, 13 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 0c62d81..2775069 100644
--- a/composer.json
+++ b/composer.json
@@ -49,7 +49,7 @@
}
],
"require": {
- "php": ">=5.3",
+ "php": ">=5.4",
"ext-bcmath": "*",
"ext-date": "*",
"ext-gd": "*",
diff --git a/php-tecnickcom-tc-lib-barcode.spec b/php-tecnickcom-tc-lib-barcode.spec
index 7e201db..726babc 100644
--- a/php-tecnickcom-tc-lib-barcode.spec
+++ b/php-tecnickcom-tc-lib-barcode.spec
@@ -6,16 +6,16 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit dd8de5620ec436d61cc8535e11f2879146ebc16b
+%global gh_commit ce05b56aba72be67df862e397189d29b151801ce
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
%global gh_project tc-lib-barcode
%global php_project %{_datadir}/php/Com/Tecnick/Barcode
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.15.20
+Version: 1.16.1
Release: 1%{?dist}
Summary: PHP library to generate linear and bidimensional barcodes
@@ -24,15 +24,11 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# For tests
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit7
-%else
-%global phpunit %{_bindir}/phpunit
-%endif
BuildRequires: %{phpunit}
-BuildRequires: php(language) >= 5.3
+BuildRequires: php(language) >= 5.4
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.12.13 with php-composer(%{c_vendor}/tc-lib-color) < 2)
%else
@@ -49,13 +45,13 @@ BuildRequires: php-pecl-imagick
%endif
# From composer.json, "require": {
-# "php": ">=5.3"
+# "php": ">=5.4"
# "ext-bcmath": "*",
# "ext-date": "*",
# "ext-gd": "*",
# "ext-pcre": "*",
# "tecnickcom/tc-lib-color": "^1.12.15"
-Requires: php(language) >= 5.3
+Requires: php(language) >= 5.4
Requires: php-bcmath
Requires: php-ctype
Requires: php-date
@@ -113,7 +109,7 @@ cp -p resources/autoload.php \
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
cat <<EOF | tee vendor/autoload.php
<?php
@@ -123,7 +119,7 @@ require __DIR__ . '/../test/TestStrings.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
@@ -144,6 +140,9 @@ exit $ret
%changelog
+* Tue Jul 14 2020 Remi Collet <remi@remirepo.net> - 1.16.1-1
+- update to 1.16.1
+
* Fri Jan 3 2020 Remi Collet <remi@remirepo.net> - 1.15.20-1
- update to 1.15.20