summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-14 07:16:14 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-14 07:16:14 +0200
commit846dd0e5dbc70c81ea73c0122c4c80cbd8c7709b (patch)
tree9e4a6c7d54f6bbcbf2136129361f65833048af96
parent006d5e754d7df57deda638cc74249b4455c782f4 (diff)
php-tecnickcom-tc-lib-barcode: 1.9.0 (no change)
-rw-r--r--composer.json40
-rw-r--r--php-tecnickcom-tc-lib-barcode.spec11
2 files changed, 47 insertions, 4 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..f54705f
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,40 @@
+{
+ "name": "tecnickcom/tc-lib-barcode",
+ "description": "PHP library to generate linear and bidimensional barcodes",
+ "type": "library",
+ "homepage": "http://www.tecnick.com",
+ "license": "LGPL-3.0",
+ "keywords": ["tc-lib-barcode", "barcode", "CODE 39", "ANSI MH10.8M-1983", "USD-3", "3 of 9", "CODE 93", "USS-93", "Standard 2 of 5", "Interleaved 2 of 5", "CODE 128 A B C", "UPC", "EAN 8", "EAN 13", "UPC-A", "UPC-E", "MSI", "POSTNET", "PLANET", "RMS4CC", "Royal Mail", "CBC", "KIX", "Klant", "Intelligent Mail Barcode", "Onecode", "USPS-B-3200", "CODABAR", "CODE 11", "PHARMACODE", "PHARMACODE TWO-TRACKS", "Datamatrix", "ECC200", "QR-Code", "PDF417"],
+ "authors": [
+ {
+ "name": "Nicola Asuni",
+ "email": "info@tecnick.com",
+ "role": "lead"
+ }
+ ],
+ "require": {
+ "php": ">=5.4",
+ "tecnickcom/tc-lib-color": "^1.11.0"
+ },
+ "require-dev": {
+ "apigen/apigen" : "^4.1.2",
+ "bartlett/php-compatinfo" : "^5.0.0",
+ "pdepend/pdepend" : "^2.2.2",
+ "phploc/phploc" : "^2.1.5|^3.0.0",
+ "phpmd/phpmd" : "^2.3.2",
+ "phpunit/phpunit": "4.8.19|^5.0.0",
+ "sebastian/phpcpd" : "^2.0.2",
+ "squizlabs/php_codesniffer": "^2.5.0|^3.0.0"
+ },
+ "autoload": {
+ "psr-4":{
+ "Com\\Tecnick\\Barcode\\": "src"
+ }
+ },
+ "repositories": [
+ {
+ "type": "vcs",
+ "url": "git@github.com:tecnickcom/tc-lib-color.git"
+ }
+ ]
+}
diff --git a/php-tecnickcom-tc-lib-barcode.spec b/php-tecnickcom-tc-lib-barcode.spec
index 50d56a5..5fbcba7 100644
--- a/php-tecnickcom-tc-lib-barcode.spec
+++ b/php-tecnickcom-tc-lib-barcode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 33b248762ecf67af522139850b4d8b8ddabfa688
+%global gh_commit 2e574593447df2f935aa1cee1a16724fdcc15c3f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.8.0
+Version: 1.9.0
Release: 1%{?dist}
Summary: PHP library to generate linear and bidimensional barcodes
@@ -41,9 +41,9 @@ BuildRequires: php-pecl-imagick
# From composer.json, "require": {
# "php": ">=5.4"
-# "tecnickcom/tc-lib-color": "^1.8.0"
+# "tecnickcom/tc-lib-color": "^1.11.0"
Requires: php(language) >= 5.4
-Requires: php-composer(%{c_vendor}/tc-lib-color) >= 1.10.0
+Requires: php-composer(%{c_vendor}/tc-lib-color) >= 1.11.0
Requires: php-composer(%{c_vendor}/tc-lib-color) < 2
# From phpcompatinfo report for version 1.1.2
Requires: php-bcmath
@@ -127,6 +127,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 1.9.0-1
+- update to 1.9.0 (no change)
+
* Thu Mar 10 2016 Remi Collet <remi@fedoraproject.org> - 1.8.0-1
- update to 1.8.0
- raise dependency on tecnickcom/tc-lib-color >= 1.10.0