summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-15 06:49:35 +0200
committerRemi Collet <remi@remirepo.net>2018-05-15 06:49:35 +0200
commit5ab7c305e3c545d57bad6fb9a3a59b2ba1caa506 (patch)
treee3f26d974966f0db36d3923bd4119fd863488fb7
parentb39816583fa45c0a6c0772631d104cdb3770cd8b (diff)
update to 1.15.11 (no change)
-rw-r--r--composer.json8
-rw-r--r--php-tecnickcom-tc-lib-barcode.spec15
2 files changed, 13 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 4b1d038..709094f 100644
--- a/composer.json
+++ b/composer.json
@@ -49,16 +49,16 @@
}
],
"require": {
- "php": ">=5.4",
+ "php": ">=5.3",
"ext-bcmath": "*",
"ext-date": "*",
"ext-gd": "*",
"ext-pcre": "*",
- "tecnickcom/tc-lib-color": "^1.12.10"
+ "tecnickcom/tc-lib-color": "^1.12.11"
},
"require-dev": {
- "apigen/apigen": "^4.1.2",
- "bartlett/php-compatinfo": "^5.0.10 || ^5.0.12",
+ "apigen/apigen": "^2.8.1 || ^4.1.2",
+ "bartlett/php-compatinfo": "^4.5.2 || ^5.0.10 || ^5.0.12",
"pdepend/pdepend": "^2.5.2",
"phploc/phploc": "^2.1 || ^3.0 || ^4.0",
"phpmd/phpmd": "^2.6.0",
diff --git a/php-tecnickcom-tc-lib-barcode.spec b/php-tecnickcom-tc-lib-barcode.spec
index ed7af72..b91f86c 100644
--- a/php-tecnickcom-tc-lib-barcode.spec
+++ b/php-tecnickcom-tc-lib-barcode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 2dc7d0d1087dda4961bd4af03a6575a510146f3e
+%global gh_commit e471bf39c533b5332ab31ecd53ec514be61ffa58
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.15.10
+Version: 1.15.11
Release: 1%{?dist}
Summary: PHP library to generate linear and bidimensional barcodes
@@ -32,7 +32,7 @@ BuildArch: noarch
%global phpunit %{_bindir}/phpunit
%endif
BuildRequires: %{phpunit}
-BuildRequires: php(language) >= 5.4
+BuildRequires: php(language) >= 5.3
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1 with php-composer(%{c_vendor}/tc-lib-color) < 2)
%else
@@ -48,13 +48,13 @@ BuildRequires: php-pecl-imagick
%endif
# From composer.json, "require": {
-# "php": ">=5.4"
+# "php": ">=5.3"
# "ext-bcmath": "*",
# "ext-date": "*",
# "ext-gd": "*",
# "ext-pcre": "*",
-# "tecnickcom/tc-lib-color": "^1.12.4"
-Requires: php(language) >= 5.4
+# "tecnickcom/tc-lib-color": "^1.12.11"
+Requires: php(language) >= 5.3
Requires: php-bcmath
Requires: php-date
Requires: php-gd
@@ -142,6 +142,9 @@ exit $ret
%changelog
+* Tue May 15 2018 Remi Collet <remi@remirepo.net> - 1.15.11-1
+- update to 1.15.11 (no change)
+
* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 1.15.10-1
- update to 1.15.10 (no change)
- switch to phpunit7