summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-color
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-24 10:26:40 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-24 10:26:40 +0100
commit24ac6477051aac67b676f6d4ada2db9aa72abf73 (patch)
treefc11cf52f67ca5474c12c6baed962d7fed7d48f7 /php-tecnickcom-tc-lib-color
parent37c7d18a85254e069cc12d6dce24e3e1fcd45eb4 (diff)
php/tecnick/php-tecnickcom-tc-lib-color moved to git.remirepo.net
Diffstat (limited to 'php-tecnickcom-tc-lib-color')
-rw-r--r--php-tecnickcom-tc-lib-color/Makefile4
-rw-r--r--php-tecnickcom-tc-lib-color/composer.json34
-rw-r--r--php-tecnickcom-tc-lib-color/php-tecnickcom-tc-lib-color.spec195
3 files changed, 0 insertions, 233 deletions
diff --git a/php-tecnickcom-tc-lib-color/Makefile b/php-tecnickcom-tc-lib-color/Makefile
deleted file mode 100644
index 13af741..0000000
--- a/php-tecnickcom-tc-lib-color/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-SRCDIR := $(shell pwd)
-NAME := $(shell basename $(SRCDIR))
-include ../../../common/Makefile
-
diff --git a/php-tecnickcom-tc-lib-color/composer.json b/php-tecnickcom-tc-lib-color/composer.json
deleted file mode 100644
index e8f4f9c..0000000
--- a/php-tecnickcom-tc-lib-color/composer.json
+++ /dev/null
@@ -1,34 +0,0 @@
-{
- "name": "tecnickcom/tc-lib-color",
- "description": "PHP library to manipulate various color representations",
- "type": "library",
- "homepage": "http://www.tecnick.com",
- "license": "LGPL-3.0",
- "keywords": ["tc-lib-color", "color", "colors", "colour", "colours", "javascript", "web", "rgb", "rgba", "cmyk", "hsl", "hsla"],
- "authors": [
- {
- "name": "Nicola Asuni",
- "email": "info@tecnick.com",
- "role": "lead"
- }
- ],
- "require": {
- "php": ">=5.4",
- "ext-pcre": "*"
- },
- "require-dev": {
- "apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.4",
- "pdepend/pdepend" : "^2.5.0",
- "phploc/phploc" : "^2.1.5 || ^3.0.1",
- "phpmd/phpmd" : "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
- },
- "autoload": {
- "psr-4":{
- "Com\\Tecnick\\Color\\": "src"
- }
- }
-}
diff --git a/php-tecnickcom-tc-lib-color/php-tecnickcom-tc-lib-color.spec b/php-tecnickcom-tc-lib-color/php-tecnickcom-tc-lib-color.spec
deleted file mode 100644
index c383c72..0000000
--- a/php-tecnickcom-tc-lib-color/php-tecnickcom-tc-lib-color.spec
+++ /dev/null
@@ -1,195 +0,0 @@
-# remirepo/fedora spec file for php-tecnickcom-tc-lib-color
-#
-# Copyright (c) 2015-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%global gh_commit 8921acc8e9c26bdc32c9b08989d42e428af6c660
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global c_vendor tecnickcom
-%global gh_owner tecnickcom
-%global gh_project tc-lib-color
-%global php_project %{_datadir}/php/Com/Tecnick/Color
-%global with_tests 0%{!?_without_tests:1}
-
-Name: php-%{gh_owner}-%{gh_project}
-Version: 1.12.6
-Release: 1%{?dist}
-Summary: PHP library to manipulate various color representations
-
-Group: Development/Libraries
-License: LGPLv3+
-URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildArch: noarch
-%if %{with_tests}
-# For tests
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
-%else
-%global phpunit %{_bindir}/phpunit
-%endif
-BuildRequires: %{phpunit}
-BuildRequires: php(language) >= 5.4
-Requires: php-pcre
-%endif
-
-# From composer.json, "require": {
-# "php": ">=5.4",
-# "ext-pcre": "*"
-Requires: php(language) >= 5.4
-Requires: php-pcre
-# From phpcompatinfo report for version 1.12.4
-# none
-
-# Composer
-Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
-# Upstream package name
-Provides: php-%{gh_project} = %{version}
-
-
-%description
-Provides tc-lib-color: PHP library to manipulate various color
-representations (GRAY, RGB, HSL, CMYK) and parse Web colors.
-
-The initial source code has been extracted from TCPDF (http://www.tcpdf.org).
-
-
-%prep
-%setup -q -n %{gh_project}-%{gh_commit}
-
-: Sanity check
-grep -q '^%{version}$' VERSION
-
-: Fix the examples
-sed -e 's:^require:////require:' \
- -e 's:^//require:require:' \
- -i example/*php
-
-
-%build
-# Empty build section, most likely nothing required.
-
-
-%install
-rm -rf %{buildroot}
-mkdir -p $(dirname %{buildroot}%{php_project})
-cp -pr src %{buildroot}%{php_project}
-cp -p resources/autoload.php \
- %{buildroot}%{php_project}/autoload.php
-
-
-%check
-%if %{with_tests}
-mkdir vendor
-cat <<EOF | tee vendor/autoload.php
-<?php
-require '%{buildroot}%{php_project}/autoload.php';
-EOF
-
-ret=0
-for cmd in "php %{phpunit}" \
- "php56 %{_bindir}/phpunit" \
- "php70 %{_bindir}/phpunit" \
- "php70 %{_bindir}/phpunit6" \
- "php71 %{_bindir}/phpunit6"; do
- if which $cmd; then
- $cmd --no-coverage --verbose || ret=1
- fi
-done
-exit $ret
-%else
-: Test suite disabled
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%{!?_licensedir:%global license %%doc}
-%license LICENSE
-%doc composer.json
-%doc README.md example
-%dir %{_datadir}/php/Com
-%dir %{_datadir}/php/Com/Tecnick
-%{php_project}
-
-
-%changelog
-* Sun Feb 12 2017 Remi Collet <remi@fedoraproject.org> - 1.12.6-1
-- update to 1.12.6 (no change)
-- use phpunit6 on F26+
-
-* Mon Feb 6 2017 Remi Collet <remi@fedoraproject.org> - 1.12.4-1
-- update to 1.12.4 (no change)
-
-* Fri Sep 2 2016 Remi Collet <remi@fedoraproject.org> - 1.12.1-1
-- update to 1.12.1
-
-* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 1.11.0-1
-- update to 1.11.0 (no change)
-
-* Thu Mar 10 2016 Remi Collet <remi@fedoraproject.org> - 1.10.3-1
-- update to 1.10.3 (no change)
-
-* Fri Mar 4 2016 Remi Collet <remi@fedoraproject.org> - 1.10.2-1
-- update to 1.10.2 (no change)
-
-* Wed Dec 16 2015 Remi Collet <remi@fedoraproject.org> - 1.10.0-1
-- update to 1.10.0
-
-* Fri Dec 11 2015 Remi Collet <remi@fedoraproject.org> - 1.8.0-1
-- update to 1.8.0 (no change)
-- raise dependency on php >= 5.4
-
-* Fri Dec 11 2015 Remi Collet <remi@fedoraproject.org> - 1.7.2-1
-- update to 1.7.2
-
-* Mon Dec 7 2015 Remi Collet <remi@fedoraproject.org> - 1.6.18-1
-- update to 1.6.18 (no change)
-
-* Thu Dec 3 2015 Remi Collet <remi@fedoraproject.org> - 1.6.16-1
-- update to 1.6.16 (no change)
-
-* Fri Nov 27 2015 Remi Collet <remi@fedoraproject.org> - 1.6.15-1
-- update to 1.6.15 (no change)
-
-* Wed Nov 25 2015 Remi Collet <remi@fedoraproject.org> - 1.6.14-1
-- update to 1.6.14 (no change)
-
-* Fri Nov 20 2015 Remi Collet <remi@fedoraproject.org> - 1.6.10-1
-- update to 1.6.10 (no change)
-
-* Fri Nov 20 2015 Remi Collet <remi@fedoraproject.org> - 1.6.8-1
-- update to 1.6.8 (no change)
-
-* Wed Nov 18 2015 Remi Collet <remi@fedoraproject.org> - 1.6.5-1
-- update to 1.6.5 (no change)
-- run test suite with both PHP 5 and 7 when available
-
-* Mon Oct 19 2015 Remi Collet <remi@fedoraproject.org> - 1.6.2-1
-- update to 1.6.2
-
-* Fri Sep 25 2015 Remi Collet <remi@fedoraproject.org> - 1.5.4-1
-- update to 1.5.4 (no change)
-
-* Sun Sep 13 2015 Remi Collet <remi@fedoraproject.org> - 1.5.2-1
-- update to 1.5.2
-- provide php-composer(tecnickcom/tc-lib-color)
-
-* Fri Jul 24 2015 Remi Collet <remi@fedoraproject.org> - 1.5.1-1
-- update to 1.5.1 (no change)
-
-* Thu Jul 2 2015 Remi Collet <remi@fedoraproject.org> - 1.5.0-1
-- update to 1.5.0
-
-* Wed Jul 1 2015 Remi Collet <remi@fedoraproject.org> - 1.4.5-1
-- initial package, version 1.4.5
-