summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-15 08:39:59 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-15 08:39:59 +0100
commitd3763d20aff45db71ebe10a4fb7d11ab5e2c92a1 (patch)
tree16e0cb92e246c8fd3bfc9741739c46257c1907b2
parentcaca4b2a4b73dc0051b6bcec5eedf2c59f4b547e (diff)
php-tecnickcom-tc-lib-unicode: 1.2.1, new package
-rw-r--r--builorder1
-rw-r--r--php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec2
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec2
-rw-r--r--php-tecnickcom-tc-lib-unicode/Makefile4
-rw-r--r--php-tecnickcom-tc-lib-unicode/php-tecnickcom-tc-lib-unicode.spec114
5 files changed, 121 insertions, 2 deletions
diff --git a/builorder b/builorder
index 3a600e5..ee67308 100644
--- a/builorder
+++ b/builorder
@@ -6,3 +6,4 @@ tc-lib-unicode-data 1.5.0
tc-lib-barcode 1.7.1 tc-lib-color
tc-lib-pdf-page 2.0.1 tc-lib-pdf-encrypt, tc-lib-color
tc-lib-pdf-parser 2.2.2 tc-lib-pdf-filter
+tc-lib-unicode 1.2.1 tc-lib-unicode-data
diff --git a/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec
index cc9b4f8..897e7ee 100644
--- a/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec
+++ b/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-file
#
-# Copyright (c) 2015-2016 Remi Collet
+# Copyright (c) 2016 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec
index 6f02788..a40b0f4 100644
--- a/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec
+++ b/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-encrypt
#
-# Copyright (c) 2015-2016 Remi Collet
+# Copyright (c) 2016 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
diff --git a/php-tecnickcom-tc-lib-unicode/Makefile b/php-tecnickcom-tc-lib-unicode/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/php-tecnickcom-tc-lib-unicode/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-tecnickcom-tc-lib-unicode/php-tecnickcom-tc-lib-unicode.spec b/php-tecnickcom-tc-lib-unicode/php-tecnickcom-tc-lib-unicode.spec
new file mode 100644
index 0000000..8c8950b
--- /dev/null
+++ b/php-tecnickcom-tc-lib-unicode/php-tecnickcom-tc-lib-unicode.spec
@@ -0,0 +1,114 @@
+# remirepo/fedora spec file for php-tecnickcom-tc-lib-unicode
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 114a904e806d99001842e7c344cc1f7f080b4a0b
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global c_vendor tecnickcom
+%global gh_owner tecnickcom
+%global gh_project tc-lib-unicode
+%global php_project %{_datadir}/php/Com/Tecnick/Unicode
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.2.1
+Release: 1%{?dist}
+Summary: PHP library containing Unicode methods
+
+Group: Development/Libraries
+License: LGPLv3+
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: php(language) >= 5.4
+BuildRequires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.5.0
+BuildRequires: php-mbstring
+BuildRequires: php-pcre
+%endif
+
+# From composer.json, "require": {
+# "php": ">=5.4"
+# "tecnickcom/tc-lib-unicode-data": "^1.5.0"
+Requires: php(language) >= 5.4
+Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.5.0
+Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) < 2
+# From phpcompatinfo report for version 1.2.1
+Requires: php-mbstring
+Requires: php-pcre
+
+# Composer
+Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
+# Upstream package name
+Provides: php-%{gh_project} = %{version}
+
+
+%description
+PHP library containing Unicode and UTF-8 methods, including the
+Unicode Bidirectional Algorithm.
+
+The initial source code has been derived from TCPDF (http://www.tcpdf.org/).
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+: Sanity check
+grep -q '^%{version}$' VERSION
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p $(dirname %{buildroot}%{php_project})
+cp -pr src %{buildroot}%{php_project}
+cp -p resources/autoload.php \
+ %{buildroot}%{php_project}/autoload.php
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat <<EOF | tee vendor/autoload.php
+<?php
+require '%{buildroot}%{php_project}/autoload.php';
+require '%{php_project}/Data/autoload.php';
+EOF
+
+%{_bindir}/phpunit --verbose
+
+if which php70; then
+ php70 %{_bindir}/phpunit --verbose
+fi
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc README.md
+%{php_project}/*
+
+
+%changelog
+* Fri Jan 15 2016 Remi Collet <remi@fedoraproject.org> - 1.2.1-1
+- initial package, version 1.2.1 \ No newline at end of file