summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-15 07:33:32 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-15 07:33:32 +0100
commit992dd8611e922b3665a95fcf1e6a26631d94d927 (patch)
treecad038b359f75525178e56b3107b3fc12639e18a
parent5d3deace29cad8dc24b32ef5483f143f101bb1cb (diff)
php-tecnickcom-tc-lib-pdf-encrypt: 1.3.0, new package
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt/Makefile4
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec121
2 files changed, 125 insertions, 0 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt/Makefile b/php-tecnickcom-tc-lib-pdf-encrypt/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/php-tecnickcom-tc-lib-pdf-encrypt/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec
new file mode 100644
index 0000000..6f02788
--- /dev/null
+++ b/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec
@@ -0,0 +1,121 @@
+# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-encrypt
+#
+# Copyright (c) 2015-2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit dcd8da3bdb7b7a3d4b2eeb4827e31ec20120d74b
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global c_vendor tecnickcom
+%global gh_owner tecnickcom
+%global gh_project tc-lib-pdf-encrypt
+%global php_project %{_datadir}/php/Com/Tecnick/Pdf/Encrypt
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.3.0
+Release: 1%{?dist}
+Summary: PHP library to encrypt data for PDF
+
+Group: Development/Libraries
+License: LGPLv3+
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: php(language) >= 5.4
+BuildRequires: php-date
+BuildRequires: php-hash
+BuildRequires: php-mcrypt
+BuildRequires: php-openssl
+BuildRequires: php-pcre
+BuildRequires: php-posix
+%endif
+
+# From composer.json, "require": {
+# "php": ">=5.4"
+Requires: php(language) >= 5.4
+# From phpcompatinfo report for version 1.3.0
+Requires: php-date
+Requires: php-hash
+# mcrypt is optional, openssl preferred
+Requires: php-openssl
+Requires: php-pcre
+Requires: php-posix
+
+
+# Composer
+Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
+# Upstream package name
+Provides: php-%{gh_project} = %{version}
+
+
+%description
+PHP library to encrypt data for PDF.
+
+The initial source code has been extracted from TCPDF (http://www.tcpdf.org).
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+: Sanity check
+grep -q '^%{version}$' VERSION
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p $(dirname %{buildroot}%{php_project})
+cp -pr src %{buildroot}%{php_project}
+cp -p resources/autoload.php \
+ %{buildroot}%{php_project}/autoload.php
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat <<EOF | tee vendor/autoload.php
+<?php
+date_default_timezone_set("Europe/London");
+require '%{buildroot}%{php_project}/autoload.php';
+EOF
+
+php %{_bindir}/phpunit --verbose
+
+if which php70; then
+ php70 %{_bindir}/phpunit --verbose
+fi
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc README.md
+%dir %{_datadir}/php/Com
+%dir %{_datadir}/php/Com/Tecnick
+%dir %{_datadir}/php/Com/Tecnick/Pdf
+%{php_project}
+
+
+%changelog
+* Fri Jan 15 2016 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
+- initial package, version 1.3.0 \ No newline at end of file