summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-24 10:27:20 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-24 10:27:20 +0100
commit967f6de5a1c36ae4838712c72e5023249f1ec866 (patch)
tree4f6ff2b0261c5bc2539c7855c156da2dca9d5288
parentd0a45532bd5ac8825542c9280ed404b57575ae73 (diff)
php/tecnick/php-tecnickcom-tc-lib-pdf-encrypt moved to git.remirepo.net
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt/Makefile4
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt/composer.json38
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec154
3 files changed, 0 insertions, 196 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt/Makefile b/php-tecnickcom-tc-lib-pdf-encrypt/Makefile
deleted file mode 100644
index 13af741..0000000
--- a/php-tecnickcom-tc-lib-pdf-encrypt/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-SRCDIR := $(shell pwd)
-NAME := $(shell basename $(SRCDIR))
-include ../../../common/Makefile
-
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt/composer.json b/php-tecnickcom-tc-lib-pdf-encrypt/composer.json
deleted file mode 100644
index dba2ee0..0000000
--- a/php-tecnickcom-tc-lib-pdf-encrypt/composer.json
+++ /dev/null
@@ -1,38 +0,0 @@
-{
- "name": "tecnickcom/tc-lib-pdf-encrypt",
- "description": "PHP library to encrypt data for PDF",
- "type": "library",
- "homepage": "http://www.tecnick.com",
- "license": "LGPL-3.0",
- "keywords": ["tc-lib-pdf-encrypt", "PDF", "encrypt", "encryption", "AES", "RC4"],
- "authors": [
- {
- "name": "Nicola Asuni",
- "email": "info@tecnick.com",
- "role": "lead"
- }
- ],
- "require": {
- "php": ">=5.4",
- "ext-date": "*",
- "ext-hash": "*",
- "ext-openssl": "*",
- "ext-pcre": "*",
- "ext-posix": "*"
- },
- "require-dev": {
- "apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.4",
- "pdepend/pdepend" : "^2.5.0",
- "phploc/phploc" : "^2.1.5 || ^3.0.1",
- "phpmd/phpmd" : "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
- },
- "autoload": {
- "psr-4":{
- "Com\\Tecnick\\Pdf\\Encrypt\\": "src"
- }
- }
-}
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec
deleted file mode 100644
index a3f2d98..0000000
--- a/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec
+++ /dev/null
@@ -1,154 +0,0 @@
-# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-encrypt
-#
-# Copyright (c) 2016-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%global gh_commit 0da81c1f2ec073781e1650bc64915d26ff19ebe9
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global c_vendor tecnickcom
-%global gh_owner tecnickcom
-%global gh_project tc-lib-pdf-encrypt
-%global php_project %{_datadir}/php/Com/Tecnick/Pdf/Encrypt
-%global with_tests 0%{!?_without_tests:1}
-
-Name: php-%{gh_owner}-%{gh_project}
-Version: 1.5.2
-Release: 1%{?dist}
-Summary: PHP library to encrypt data for PDF
-
-Group: Development/Libraries
-License: LGPLv3+
-URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildArch: noarch
-%if %{with_tests}
-# For tests
-BuildRequires: php-composer(phpunit/phpunit)
-BuildRequires: php(language) >= 5.4
-BuildRequires: php-date
-BuildRequires: php-hash
-BuildRequires: php-openssl
-BuildRequires: php-pcre
-BuildRequires: php-posix
-%endif
-
-# From composer.json, "require": {
-# "php": ">=5.4",
-# "ext-date": "*",
-# "ext-hash": "*",
-# "ext-openssl": "*",
-# "ext-pcre": "*",
-# "ext-posix": "*"
-Requires: php(language) >= 5.4
-Requires: php-date
-Requires: php-hash
-Requires: php-openssl
-Requires: php-pcre
-Requires: php-posix
-# From phpcompatinfo report for version 1.5.0
-# none
-
-# Composer
-Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
-# Upstream package name
-Provides: php-%{gh_project} = %{version}
-
-
-%description
-PHP library to encrypt data for PDF.
-
-The initial source code has been extracted from TCPDF (http://www.tcpdf.org).
-
-
-%prep
-%setup -q -n %{gh_project}-%{gh_commit}
-
-: Sanity check
-grep -q '^%{version}$' VERSION
-
-
-%build
-# Empty build section, most likely nothing required.
-
-
-%install
-rm -rf %{buildroot}
-mkdir -p $(dirname %{buildroot}%{php_project})
-cp -pr src %{buildroot}%{php_project}
-cp -p resources/autoload.php \
- %{buildroot}%{php_project}/autoload.php
-
-
-%check
-%if %{with_tests}
-mkdir vendor
-cat <<EOF | tee vendor/autoload.php
-<?php
-date_default_timezone_set("UTC");
-require '%{buildroot}%{php_project}/autoload.php';
-EOF
-
-ret=0
-for cmd in php56 php; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --no-coverage --verbose || ret=1
- fi
-done
-for cmd in php70 php71; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 --no-coverage --verbose || ret=1
- fi
-done
-exit $ret
-%else
-: Test suite disabled
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%{!?_licensedir:%global license %%doc}
-%license LICENSE
-%doc composer.json
-%doc README.md
-%dir %{_datadir}/php/Com
-%dir %{_datadir}/php/Com/Tecnick
-%dir %{_datadir}/php/Com/Tecnick/Pdf
-%{php_project}
-
-
-%changelog
-* Sun Feb 12 2017 Remi Collet <remi@fedoraproject.org> - 1.5.2-1
-- update to 1.5.2 (no change)
-
-* Wed Feb 8 2017 Remi Collet <remi@fedoraproject.org> - 1.5.0-1
-- update to 1.5.0
-- drop dependency on php-mcrypt
-
-* Mon Feb 6 2017 Remi Collet <remi@fedoraproject.org> - 1.4.4-1
-- update to 1.4.4 (no change)
-- open https://github.com/tecnickcom/tc-lib-pdf-encrypt/issues/4 - 7.1 failure
-- open https://github.com/tecnickcom/tc-lib-pdf-encrypt/pull/5 add 7.1 to travis
-- open https://github.com/tecnickcom/tc-lib-pdf-encrypt/pull/6 better exception
-
-* Fri Sep 2 2016 Remi Collet <remi@fedoraproject.org> - 1.4.3-1
-- update to 1.4.3
-
-* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 1.4.0-1
-- update to 1.4.0 (no change)
-
-* Fri Mar 4 2016 Remi Collet <remi@fedoraproject.org> - 1.3.2-1
-- update to 1.3.2 (no change)
-
-* Fri Jan 15 2016 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
-- initial package, version 1.3.0
-