summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-24 10:27:58 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-24 10:27:58 +0100
commit6c8203b260dc48b05a4de840a17b0244b2e6378d (patch)
tree71f879ae1785bd472df02b595bf6211777c2e48f
parent990b27bca02de138ac16990b1fd187275afd4d3b (diff)
php/tecnick/php-tecnickcom-tc-lib-pdf-graph moved to git.remirepo.net
-rw-r--r--php-tecnickcom-tc-lib-pdf-graph/Makefile4
-rw-r--r--php-tecnickcom-tc-lib-pdf-graph/composer.json46
-rw-r--r--php-tecnickcom-tc-lib-pdf-graph/php-tecnickcom-tc-lib-pdf-graph.spec145
3 files changed, 0 insertions, 195 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-graph/Makefile b/php-tecnickcom-tc-lib-pdf-graph/Makefile
deleted file mode 100644
index 13af741..0000000
--- a/php-tecnickcom-tc-lib-pdf-graph/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-SRCDIR := $(shell pwd)
-NAME := $(shell basename $(SRCDIR))
-include ../../../common/Makefile
-
diff --git a/php-tecnickcom-tc-lib-pdf-graph/composer.json b/php-tecnickcom-tc-lib-pdf-graph/composer.json
deleted file mode 100644
index 5cfbcbc..0000000
--- a/php-tecnickcom-tc-lib-pdf-graph/composer.json
+++ /dev/null
@@ -1,46 +0,0 @@
-{
- "name": "tecnickcom/tc-lib-pdf-graph",
- "description": "PHP library containing PDF graphic and geometric methods",
- "type": "library",
- "homepage": "http://www.tecnick.com",
- "license": "LGPL-3.0",
- "keywords": ["tc-lib-pdf-graph", "PDF", "graphic", "geometry", "transformation"],
- "authors": [
- {
- "name": "Nicola Asuni",
- "email": "info@tecnick.com",
- "role": "lead"
- }
- ],
- "require": {
- "php": ">=5.4",
- "ext-zlib": "*",
- "tecnickcom/tc-lib-color": "^1.12.6",
- "tecnickcom/tc-lib-pdf-encrypt": "^1.5.2"
- },
- "require-dev": {
- "apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.4",
- "pdepend/pdepend" : "^2.5.0",
- "phploc/phploc" : "^2.1.5 || ^3.0.1",
- "phpmd/phpmd" : "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
- },
- "autoload": {
- "psr-4":{
- "Com\\Tecnick\\Pdf\\Graph\\": "src"
- }
- },
- "repositories": [
- {
- "type": "vcs",
- "url": "git@github.com:tecnickcom/tc-lib-color.git"
- },
- {
- "type": "vcs",
- "url": "git@github.com:tecnickcom/tc-lib-pdf-encrypt.git"
- }
- ]
-}
diff --git a/php-tecnickcom-tc-lib-pdf-graph/php-tecnickcom-tc-lib-pdf-graph.spec b/php-tecnickcom-tc-lib-pdf-graph/php-tecnickcom-tc-lib-pdf-graph.spec
deleted file mode 100644
index 3530f08..0000000
--- a/php-tecnickcom-tc-lib-pdf-graph/php-tecnickcom-tc-lib-pdf-graph.spec
+++ /dev/null
@@ -1,145 +0,0 @@
-# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-graph
-#
-# Copyright (c) 2016-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%global gh_commit 264bed779bdb1f4e2ab17cfb611256e37a042d2d
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global c_vendor tecnickcom
-%global gh_owner tecnickcom
-%global gh_project tc-lib-pdf-graph
-%global php_project %{_datadir}/php/Com/Tecnick/Pdf/Graph
-%global with_tests 0%{!?_without_tests:1}
-
-Name: php-%{gh_owner}-%{gh_project}
-Version: 1.4.4
-Release: 1%{?dist}
-Summary: PHP library containing PDF graphic and geometric methods
-
-Group: Development/Libraries
-License: LGPLv3+
-URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildArch: noarch
-%if %{with_tests}
-# For tests
-BuildRequires: php-composer(phpunit/phpunit)
-BuildRequires: php(language) >= 5.4
-BuildRequires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.6
-BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2
-%endif
-
-# From composer.json, "require": {
-# "php": ">=5.4"
-# "ext-zlib": "*",
-# "tecnickcom/tc-lib-color": "^1.12.4",
-# "tecnickcom/tc-lib-pdf-encrypt": "^1.4.4"
-Requires: php(language) >= 5.4
-Requires: php-zlib
-Requires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.6
-Requires: php-composer(%{c_vendor}/tc-lib-color) < 2
-Requires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2
-Requires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2
-# From phpcompatinfo report for version 1.4.2
-# none
-
-# Composer
-Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
-# Upstream package name
-Provides: php-%{gh_project} = %{version}
-
-
-%description
-PHP library containing PDF graphic and geometric methods.
-
-The initial source code has been extracted from TCPDF (http://www.tcpdf.org).
-
-
-%prep
-%setup -q -n %{gh_project}-%{gh_commit}
-
-: Sanity check
-grep -q '^%{version}$' VERSION
-
-
-%build
-# Empty build section, most likely nothing required.
-
-
-%install
-rm -rf %{buildroot}
-mkdir -p $(dirname %{buildroot}%{php_project})
-cp -pr src %{buildroot}%{php_project}
-cp -p resources/autoload.php \
- %{buildroot}%{php_project}/autoload.php
-
-
-%check
-%if %{with_tests}
-mkdir vendor
-cat <<EOF | tee vendor/autoload.php
-<?php
-require '%{buildroot}%{php_project}/autoload.php';
-require '%{php_project}/../../Color/autoload.php';
-EOF
-
-ret=0
-for cmd in php56 php; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --no-coverage --verbose || ret=1
- fi
-done
-for cmd in php70 php71; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 --no-coverage --verbose || ret=1
- fi
-done
-exit $ret
-%else
-: Test suite disabled
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%{!?_licensedir:%global license %%doc}
-%license LICENSE
-%doc composer.json
-%doc README.md
-%dir %{_datadir}/php/Com/Tecnick/Pdf
-%{php_project}
-
-
-%changelog
-* Sun Feb 12 2017 Remi Collet <remi@remirepo.net> - 1.4.4-1
-- update to 1.4.4 (no change)
-
-* Mon Feb 6 2017 Remi Collet <remi@remirepo.net> - 1.4.3-1
-- update to 1.4.3 (no change)
-
-* Tue Sep 27 2016 Remi Collet <remi@fedoraproject.org> - 1.4.2-1
-- update to 1.4.2
-
-* Fri Sep 2 2016 Remi Collet <remi@fedoraproject.org> - 1.4.1-1
-- update to 1.4.1
-- raise dependency on tecnickcom/tc-lib-color >= 1.12.1
-- add dependency on tecnickcom/tc-lib-pdf-encrypt
-
-* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
-- update to 1.1.0 (no change)
-
-* Fri Mar 4 2016 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
-- update to 1.0.2 (no change)
-
-* Fri Jan 15 2016 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
-- initial package, version 1.0.1
-