summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-06 08:20:29 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-06 08:20:29 +0100
commit52d7e1171a2ac66bcf981dca2709272a2201ab68 (patch)
tree4de2444d38034d373dbf76af35562ad74d2b719e
parent4528b0d2e5d3013c7003eb26b3f1e107fa1c8b08 (diff)
php-tecnickcom-tc-lib-file: 1.6.4
-rw-r--r--php-tecnickcom-tc-lib-file/composer.json4
-rw-r--r--php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec33
2 files changed, 18 insertions, 19 deletions
diff --git a/php-tecnickcom-tc-lib-file/composer.json b/php-tecnickcom-tc-lib-file/composer.json
index a81789f..3bc1cc5 100644
--- a/php-tecnickcom-tc-lib-file/composer.json
+++ b/php-tecnickcom-tc-lib-file/composer.json
@@ -13,7 +13,9 @@
}
],
"require": {
- "php": ">=5.4"
+ "php": ">=5.4",
+ "ext-curl": "*",
+ "ext-pcre": "*"
},
"require-dev": {
"apigen/apigen" : "^4.1.2",
diff --git a/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec
index c1ebf0a..bd4da34 100644
--- a/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec
+++ b/php-tecnickcom-tc-lib-file/php-tecnickcom-tc-lib-file.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit ea536ea2c215c2e1eb2ecb316d3201321619d5b1
+%global gh_commit 25883874ca399300d2b631034c6a89817204631d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.6.3
+Version: 1.6.4
Release: 1%{?dist}
Summary: PHP library to read byte-level data from files
@@ -35,11 +35,14 @@ BuildRequires: php-pcre
%endif
# From composer.json, "require": {
-# "php": ">=5.4"
+# "php": ">=5.4",
+# "ext-curl": "*",
+# "ext-pcre": "*"
Requires: php(language) >= 5.4
-# From phpcompatinfo report for version 1.2.0
Requires: php-curl
Requires: php-pcre
+# From phpcompatinfo report for version 1.6.4
+# none
# Composer
Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
@@ -82,21 +85,12 @@ EOF
sed -i 's:src:File:g' -i test/DirTest.php
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php56 php70 php71 php; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
@@ -119,6 +113,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Feb 6 2017 Remi Collet <remi@remirepo.net> - 1.6.4-1
+- update to 1.6.4 (no change)
+
* Fri Sep 2 2016 Remi Collet <remi@fedoraproject.org> - 1.6.3-1
- update to 1.6.3 (no change)