summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-14 07:20:30 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-14 07:20:30 +0200
commit199a61d0fef7316bdea6c74f2e7cdddf375dcac6 (patch)
tree9543b692a9973d2f0b7b42fcb97ac66642251b07
parent306ec75e381079230a0cc063b55b5cc448112bc8 (diff)
php-tecnickcom-tc-lib-pdf-encrypt: 1.4.0 (no change)
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt/composer.json33
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec9
2 files changed, 39 insertions, 3 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt/composer.json b/php-tecnickcom-tc-lib-pdf-encrypt/composer.json
new file mode 100644
index 0000000..9a688c5
--- /dev/null
+++ b/php-tecnickcom-tc-lib-pdf-encrypt/composer.json
@@ -0,0 +1,33 @@
+{
+ "name": "tecnickcom/tc-lib-pdf-encrypt",
+ "description": "PHP library to encrypt data for PDF",
+ "type": "library",
+ "homepage": "http://www.tecnick.com",
+ "license": "LGPL-3.0",
+ "keywords": ["tc-lib-pdf-encrypt", "PDF", "encrypt", "encryption", "AES", "RC4"],
+ "authors": [
+ {
+ "name": "Nicola Asuni",
+ "email": "info@tecnick.com",
+ "role": "lead"
+ }
+ ],
+ "require": {
+ "php": ">=5.4"
+ },
+ "require-dev": {
+ "apigen/apigen" : "^4.1.2",
+ "bartlett/php-compatinfo" : "^5.0.0",
+ "pdepend/pdepend" : "^2.2.2",
+ "phploc/phploc" : "^2.1.5|^3.0.0",
+ "phpmd/phpmd" : "^2.3.2",
+ "phpunit/phpunit": "4.8.19|^5.0.0",
+ "sebastian/phpcpd" : "^2.0.2",
+ "squizlabs/php_codesniffer": "^2.5.0|^3.0.0"
+ },
+ "autoload": {
+ "psr-4":{
+ "Com\\Tecnick\\Pdf\\Encrypt\\": "src"
+ }
+ }
+}
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec
index 14d5311..17a3d50 100644
--- a/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec
+++ b/php-tecnickcom-tc-lib-pdf-encrypt/php-tecnickcom-tc-lib-pdf-encrypt.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 0772baff33d55a4ce4fb42e0815a414e60648cb3
+%global gh_commit ef09ded22d3c8a6117f2aec02a5ceaf41d26bb1f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.3.2
+Version: 1.4.0
Release: 1%{?dist}
Summary: PHP library to encrypt data for PDF
@@ -86,7 +86,7 @@ cp -p resources/autoload.php \
mkdir vendor
cat <<EOF | tee vendor/autoload.php
<?php
-date_default_timezone_set("Europe/London");
+date_default_timezone_set("UTC");
require '%{buildroot}%{php_project}/autoload.php';
EOF
@@ -117,6 +117,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 1.4.0-1
+- update to 1.4.0 (no change)
+
* Fri Mar 4 2016 Remi Collet <remi@fedoraproject.org> - 1.3.2-1
- update to 1.3.2 (no change)