summaryrefslogtreecommitdiffstats
path: root/php-symfony2-Yaml.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-30 17:13:06 +0100
committerRemi Collet <fedora@famillecollet.com>2012-10-30 17:13:06 +0100
commit0accf3efe0fd0e5f5281ccaab4e010100c84d857 (patch)
treea0b863f13028f5d1fed065dcfd695c842badf416 /php-symfony2-Yaml.spec
parent01ca6cea04117b1fbeb366cabb082d2df0074d16 (diff)
php-symfony2-Yaml: sync with rawhide, update to 2.1.3
Diffstat (limited to 'php-symfony2-Yaml.spec')
-rw-r--r--php-symfony2-Yaml.spec70
1 files changed, 49 insertions, 21 deletions
diff --git a/php-symfony2-Yaml.spec b/php-symfony2-Yaml.spec
index 7fe21db..08cf2fe 100644
--- a/php-symfony2-Yaml.spec
+++ b/php-symfony2-Yaml.spec
@@ -1,30 +1,39 @@
-%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%global pear_channel pear.symfony.com
%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
-# Can't run in mock because circular dependency on PHPUnit
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%global php_min_ver 5.3.3
Name: php-symfony2-Yaml
-Version: 2.1.2
-Release: 2%{?dist}
+Version: 2.1.3
+Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
Group: Development/Libraries
License: MIT
URL: http://symfony.com/doc/current/components/yaml.html
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+Patch0: %{name}-tests-bootstrap.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
+
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
-%if %{with_tests}
+# Test requires
+BuildRequires: php-common >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
-%endif
-
-Requires: php-common >= 5.3.2
+# Test requires: phpci
+BuildRequires: php-ctype
+BuildRequires: php-date
+BuildRequires: php-iconv
+BuildRequires: php-json
+BuildRequires: php-mbstring
+BuildRequires: php-pcre
+BuildRequires: php-spl
+
+Requires: php(language) >= %{php_min_ver}
Requires: php-pear(PEAR)
Requires: php-channel(%{pear_channel})
Requires(post): %{__pear}
@@ -56,10 +65,19 @@ specification.
%prep
%setup -q -c
-# Hum...
+# Patches
+cd %{pear_name}-%{version}
+%patch0 -p0
+cd ..
+
+# Modify PEAR package.xml file:
+# - Change role from "php" to "doc" for CHANGELOG.md file
+# - Change role from "php" to "test" for all test files
+# - Remove md5sum from bootsrap.php file since it was patched
sed -e '/CHANGELOG.md/s/role="php"/role="doc"/' \
-e '/phpunit.xml.dist/s/role="php"/role="test"/' \
-e '/Tests/s/role="php"/role="test"/' \
+ -e '/bootstrap.php/s/md5sum="[^"]*"\s*//' \
-i package.xml
# package.xml is version 2.0
@@ -72,23 +90,19 @@ mv package.xml %{pear_name}-%{version}/%{name}.xml
%install
cd %{pear_name}-%{version}
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
-%if %{with_tests}
-cd %{pear_name}-%{version}/Symfony/Component/Yaml/Tests
-phpunit --bootstrap bootstrap.php .
-%else
-: Tests skipped, missing --with tests option
-%endif
+cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
+%{_bindir}/phpunit
%post
@@ -110,10 +124,24 @@ fi
%dir %{pear_phpdir}/Symfony
%dir %{pear_phpdir}/Symfony/Component
%{pear_phpdir}/Symfony/Component/%{pear_name}
- %{pear_testdir}/%{pear_name}
+%{pear_testdir}/%{pear_name}
%changelog
+* Tue Oct 30 2012 Remi Collet <RPMS@FamilleCollet.com> 2.1.3-1
+- sync with rawhide, update to 2.1.3
+
+* Mon Oct 29 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.1.2-2
+- Added "%%global pear_metadir" and usage in %%install
+- Changed RPM_BUILD_ROOT to %%{buildroot}
+
+* Sat Oct 20 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.1.2-1
+- Updated to upstream version 2.1.2
+- PHP minimum version 5.3.3 instead of 5.3.2
+- Added PEAR package.xml modifications
+- Added patch for tests' bootstrap.php
+- Added tests (%%check)
+
* Thu Sep 20 2012 Remi Collet <RPMS@FamilleCollet.com> 2.1.2-2
- rebuild