summaryrefslogtreecommitdiffstats
path: root/php-symfony2-Validator.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-symfony2-Validator.spec')
-rw-r--r--php-symfony2-Validator.spec33
1 files changed, 18 insertions, 15 deletions
diff --git a/php-symfony2-Validator.spec b/php-symfony2-Validator.spec
index e2b1685..a1d55a0 100644
--- a/php-symfony2-Validator.spec
+++ b/php-symfony2-Validator.spec
@@ -5,7 +5,7 @@
%global php_min_ver 5.3.3
Name: php-symfony2-Validator
-Version: 2.1.8
+Version: 2.2.0
Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
@@ -13,7 +13,6 @@ Group: Development/Libraries
License: MIT
URL: http://symfony.com/components
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Patch0: %{name}-tests-bootstrap.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -22,9 +21,9 @@ BuildRequires: php-channel(%{pear_channel})
# Test requires
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
-BuildRequires: php-pear(%{pear_channel}/HttpFoundation) >= 2.1.0
-BuildRequires: php-pear(%{pear_channel}/Locale) >= 2.1.0
-BuildRequires: php-pear(%{pear_channel}/Yaml) >= 2.1.0
+BuildRequires: php-pear(%{pear_channel}/HttpFoundation) >= 2.2.0
+BuildRequires: php-pear(%{pear_channel}/Locale) >= 2.2.0
+BuildRequires: php-pear(%{pear_channel}/Yaml) >= 2.2.0
# Test requires: phpci
BuildRequires: php-ctype
BuildRequires: php-date
@@ -56,8 +55,8 @@ Requires: php-simplexml
Requires: php-spl
Requires: php-filter
# Optional requires
-Requires: php-pear(%{pear_channel}/HttpFoundation) >= 2.1.0
-Requires: php-pear(%{pear_channel}/Yaml) >= 2.1.0
+Requires: php-pear(%{pear_channel}/HttpFoundation) >= 2.2.0
+Requires: php-pear(%{pear_channel}/Yaml) >= 2.2.0
# TODO: Add DoctrineCommon (>=2.1,<2.4-dev) when available
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -73,11 +72,6 @@ Optional dependencies: APC, DoctrineCommon
%prep
%setup -q -c
-# Patches
-cd %{pear_name}-%{version}
-%patch0 -p0
-cd ..
-
# Modify PEAR package.xml file:
# - Remove .gitignore file
# - Change role from "php" to "doc" for CHANGELOG.md file
@@ -87,7 +81,6 @@ sed -e '/\.gitignore/d' \
-e '/CHANGELOG.md/s/role="php"/role="doc"/' \
-e '/phpunit.xml.dist/s/role="php"/role="test"/' \
-e '/Tests/s/role="php"/role="test"/' \
- -e '/bootstrap.php/s/md5sum="[^"]*"\s*//' \
-i package.xml
# package.xml is version 2.0
@@ -109,11 +102,18 @@ rm -rf %{buildroot}%{pear_metadir}/.??*
mkdir -p %{buildroot}%{pear_xmldir}
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+sed -e '/bootstrap/s:vendor/autoload.php:%{pear_phpdir}/Symfony/Component/%{pear_name}/autoloader.php:' \
+ %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml.dist \
+ > %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml
+
%check
-%if 0%{?fedora} > 13
+# TODO need investigation
+%if 0
cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
-%{_bindir}/phpunit
+sed -e '/bootstrap/s:vendor/autoload.php:autoloader.php:' \
+ phpunit.xml.dist > phpunit.xml
+%{_bindir}/phpunit -d date.timezone=UTC
%else
: Test temporary disabled on EL
%endif
@@ -140,6 +140,9 @@ fi
%changelog
+* Wed Mar 06 2013 Remi Collet <remi@fedoraproject.org> - 2.2.0-1
+- Update to 2.2.0
+
* Wed Feb 27 2013 Remi Collet <remi@fedoraproject.org> - 2.1.8-1
- Update to 2.1.8