summaryrefslogtreecommitdiffstats
path: root/php-symfony2-Translation.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-symfony2-Translation.spec')
-rw-r--r--php-symfony2-Translation.spec78
1 files changed, 58 insertions, 20 deletions
diff --git a/php-symfony2-Translation.spec b/php-symfony2-Translation.spec
index 4ad7eea..ad99bc6 100644
--- a/php-symfony2-Translation.spec
+++ b/php-symfony2-Translation.spec
@@ -1,11 +1,12 @@
-%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%global pear_channel pear.symfony.com
%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
+%global php_min_ver 5.3.3
Name: php-symfony2-Translation
-Version: 2.1.2
+Version: 2.1.3
Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
@@ -13,45 +14,66 @@ Group: Development/Libraries
License: MIT
URL: http://symfony.com/components
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Source1: bootstrap.php
+Patch0: %{name}-tests-bootstrap.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
-# For tests
+# Test requires
+BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
-BuildRequires: php-pear(%{pear_channel}/Config)
-
-Requires: php-common >= 5.3.2
+BuildRequires: php-pear(%{pear_channel}/Config) >= 2.1.0
+BuildRequires: php-pear(%{pear_channel}/Yaml) >= 2.1.0
+# Test requires: phpci
+BuildRequires: php-dom
+BuildRequires: php-intl
+BuildRequires: php-libxml
+BuildRequires: php-mbstring
+BuildRequires: php-pcre
+BuildRequires: php-simplexml
+BuildRequires: php-spl
+
+Requires: php(language) >= %{php_min_ver}
Requires: php-pear(PEAR)
Requires: php-channel(%{pear_channel})
Requires(post): %{__pear}
Requires(postun): %{__pear}
# phpci requires
Requires: php-dom
+Requires: php-intl
Requires: php-libxml
+Requires: php-mbstring
Requires: php-pcre
Requires: php-simplexml
Requires: php-spl
# Optional requires
-Requires: php-pear(%{pear_channel}/Config) = %{version}
-Requires: php-pear(%{pear_channel}/Yaml) = %{version}
+Requires: php-pear(%{pear_channel}/Config) >= 2.1.0
+Requires: php-pear(%{pear_channel}/Yaml) >= 2.1.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
%description
-%{summary}.
+Translation provides tools for loading translation files and generating
+translated strings from these including support for pluralization.
%prep
%setup -q -c
-# Hum...
-sed -e '/CHANGELOG.md/s/role="php"/role="doc"/' \
+# Patches
+cd %{pear_name}-%{version}
+%patch0 -p0
+cd ..
+
+# Modify PEAR package.xml file:
+# - Remove .gitignore file
+# - Change role from "php" to "doc" for CHANGELOG.md file
+# - Change role from "php" to "test" for all test files
+sed -e '/.git/d' \
+ -e '/CHANGELOG.md/s/role="php"/role="doc"/' \
-e '/phpunit.xml.dist/s/role="php"/role="test"/' \
-e '/Tests/s/role="php"/role="test"/' \
- -e '/.gitignore/d' \
-i package.xml
# package.xml is version 2.0
@@ -64,20 +86,19 @@ mv package.xml %{pear_name}-%{version}/%{name}.xml
%install
cd %{pear_name}-%{version}
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
-cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}/Tests
-cp %{SOURCE1} bootstrap.php
-phpunit --bootstrap bootstrap.php --verbose .
+cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
+%{_bindir}/phpunit
%post
@@ -101,6 +122,23 @@ fi
%changelog
+* Tue Oct 30 2012 Remi Collet <RPMS@FamilleCollet.com> 2.1.3-1
+- sync with rawhide, update to 2.1.3
+
+* Mon Oct 29 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.1.2-2
+- Added "%%global pear_metadir" and usage in %%install
+- Changed RPM_BUILD_ROOT to %%{buildroot}
+
+* Tue Oct 23 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.1.2-1
+- Updated to upstream version 2.1.2
+- Updated description
+- PHP minimum version 5.3.3 instead of 5.3.2
+- Added php-intl and php-mbstring requires
+- Require other components ">= 2.1.0" instead of "= %%{version}"
+- Added PEAR package.xml modifications
+- Added patch for tests' bootstrap.php
+- Added tests (%%check)
+
* Sat Oct 6 2012 Remi Collet <RPMS@FamilleCollet.com> 2.1.2-1
- update to 2.1.2