summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-04-06 18:55:33 +0200
committerRemi Collet <fedora@famillecollet.com>2013-04-06 18:55:33 +0200
commita11dd1f10351f91128f89d325f8c39ed129d1f3b (patch)
treedf3c4b54f28b488ce02634e8d0280d3afed5a42e
parentfa4448d1398a1982d7c94dd35df7d362b2ce487b (diff)
php-symfony2-Security: sync with rawhide
-rw-r--r--php-symfony2-Security.spec108
1 files changed, 84 insertions, 24 deletions
diff --git a/php-symfony2-Security.spec b/php-symfony2-Security.spec
index 5128aa6..940ffe4 100644
--- a/php-symfony2-Security.spec
+++ b/php-symfony2-Security.spec
@@ -1,10 +1,10 @@
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
%global pear_channel pear.symfony.com
-%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
+%global pear_name Security
%global php_min_ver 5.3.3
-Name: php-symfony2-Security
+Name: php-symfony2-%{pear_name}
Version: 2.2.0
Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
@@ -16,25 +16,36 @@ Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
+
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
-# Test requires
+# For tests
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
BuildRequires: php-pear(%{pear_channel}/EventDispatcher) >= 2.2.0
+BuildRequires: php-pear(%{pear_channel}/EventDispatcher) < 2.3.0
+BuildRequires: php-pear(%{pear_channel}/Form) >= 2.2.0
+BuildRequires: php-pear(%{pear_channel}/Form) < 2.3.0
BuildRequires: php-pear(%{pear_channel}/HttpFoundation) >= 2.2.0
+BuildRequires: php-pear(%{pear_channel}/HttpFoundation) < 2.3.0
BuildRequires: php-pear(%{pear_channel}/HttpKernel) >= 2.2.0
-BuildRequires: php-pear(%{pear_channel}/Form) >= 2.2.0
+BuildRequires: php-pear(%{pear_channel}/HttpKernel) < 2.3.0
BuildRequires: php-pear(%{pear_channel}/Routing) >= 2.2.0
+BuildRequires: php-pear(%{pear_channel}/Routing) < 2.3.0
BuildRequires: php-pear(%{pear_channel}/Validator) >= 2.2.0
-# TODO: Add DoctrineCommon and DoctrineDBAL (>=2.2,<2.4-dev) when available
-# Test requires: phpci
+BuildRequires: php-pear(%{pear_channel}/Validator) < 2.3.0
+BuildRequires: php-pear(pear.doctrine-project.org/DoctrineCommon) >= 2.2.0
+BuildRequires: php-pear(pear.doctrine-project.org/DoctrineCommon) < 3.0.0
+BuildRequires: php-PsrLog >= 1.0
+BuildRequires: php-PsrLog < 2.0
+# TODO: Add DoctrineDBAL (>=2.2,<3) when available
+# For tests: phpci
BuildRequires: php-date
BuildRequires: php-hash
BuildRequires: php-json
+BuildRequires: php-mcrypt
BuildRequires: php-openssl
BuildRequires: php-pcre
-BuildRequires: php-pdo
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -42,26 +53,34 @@ Requires: php(language) >= %{php_min_ver}
Requires: php-pear(PEAR)
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/EventDispatcher) >= 2.2.0
+Requires: php-pear(%{pear_channel}/EventDispatcher) < 2.3.0
Requires: php-pear(%{pear_channel}/HttpFoundation) >= 2.2.0
+Requires: php-pear(%{pear_channel}/HttpFoundation) < 2.3.0
Requires: php-pear(%{pear_channel}/HttpKernel) >= 2.2.0
+Requires: php-pear(%{pear_channel}/HttpKernel) < 2.3.0
Requires(post): %{__pear}
Requires(postun): %{__pear}
-# phpci requires
+# phpci
Requires: php-date
Requires: php-hash
Requires: php-json
+Requires: php-mcrypt
Requires: php-openssl
Requires: php-pcre
-Requires: php-pdo
Requires: php-reflection
Requires: php-spl
-# Optional requires
+# Optional
Requires: php-pear(%{pear_channel}/ClassLoader) >= 2.2.0
+Requires: php-pear(%{pear_channel}/ClassLoader) < 2.3.0
Requires: php-pear(%{pear_channel}/Finder) >= 2.2.0
+Requires: php-pear(%{pear_channel}/Finder) < 2.3.0
Requires: php-pear(%{pear_channel}/Form) >= 2.2.0
+Requires: php-pear(%{pear_channel}/Form) < 2.3.0
Requires: php-pear(%{pear_channel}/Routing) >= 2.2.0
+Requires: php-pear(%{pear_channel}/Routing) < 2.3.0
Requires: php-pear(%{pear_channel}/Validator) >= 2.2.0
-# TODO: Add DoctrineDBAL (>=2.2,<2.4-dev) when available
+Requires: php-pear(%{pear_channel}/Validator) < 2.3.0
+# TODO: Add DoctrineDBAL (>=2.2,<3) when available
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -71,21 +90,53 @@ which makes it possible to easily separate the actual authorization logic from
so called user providers that hold the users credentials. It is inspired by
the Java Spring framework.
-Optional dependencies: DoctrineCommon and DoctrineDBAL
+Optional dependencies: DoctrineDBAL
%prep
%setup -q -c
+# Create PHPUnit autoloader
+( cat <<'PHPUNIT_AUTOLOADER'
+<?php
+
+# This file was created by RPM packaging and is not part of the original
+# Symfony2 %{pear_name} PEAR package.
+
+set_include_path(
+ '%{pear_phpdir}'.PATH_SEPARATOR.
+ '%{_datadir}/php'.PATH_SEPARATOR.
+ '%{pear_testdir}/%{pear_name}'.PATH_SEPARATOR.
+ get_include_path()
+);
+
+spl_autoload_register(function ($class) {
+ if ('\\' == $class[0]) {
+ $class = substr($class, 1);
+ }
+
+ $file = str_replace('\\', '/', $class).'.php';
+ @include $file;
+});
+PHPUNIT_AUTOLOADER
+) > phpunit.autoloader.php
+
+# Update PHPUnit config
+sed -e 's#vendor/autoload.php#./phpunit.autoloader.php#' \
+ -i %{pear_name}-%{version}/Symfony/Component/%{pear_name}/phpunit.xml.dist
+
# Modify PEAR package.xml file:
+# - Remove .gitattributes file
# - Remove .gitignore file
# - Change role from "php" to "doc" for CHANGELOG.md file
# - Change role from "php" to "test" for all test files
-# - Remove md5sum from bootsrap.php file since it was patched
-sed -e '/\.gitignore/d' \
+# - Remove md5sum from phpunit.xml.dist file since it was updated
+sed -e '/\.gitattributes/d' \
+ -e '/\.gitignore/d' \
-e '/CHANGELOG.md/s/role="php"/role="doc"/' \
- -e '/phpunit.xml.dist/s/role="php"/role="test"/' \
-e '/Tests/s/role="php"/role="test"/' \
+ -e '/phpunit.xml.dist/s/role="php"/role="test"/' \
+ -e '/phpunit.xml.dist/s/md5sum="[^"]*"\s*//' \
-i package.xml
# package.xml is version 2.0
@@ -107,19 +158,19 @@ rm -rf %{buildroot}%{pear_metadir}/.??*
mkdir -p %{buildroot}%{pear_xmldir}
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
-sed -e '/bootstrap/s:vendor/autoload.php:%{pear_phpdir}/Symfony/Component/%{pear_name}/autoloader.php:' \
- %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml.dist \
- > %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml
+# Install PHPUnit autoloader
+install -pm 0644 ../phpunit.autoloader.php \
+ %{buildroot}/%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/
%check
cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
-# TODO need investigation
-%if 0
-sed -e '/bootstrap/s:vendor/autoload.php:autoloader.php:' \
- phpunit.xml.dist > phpunit.xml
-%{_bindir}/phpunit -d date.timezone=UTC
-%endif
+
+sed 's#./phpunit.autoloader.php#./autoloader.php#' -i phpunit.xml.dist
+
+%{_bindir}/phpunit -d date.timezone="UTC" \
+ -d include_path=".:%{_datadir}/php:%{pear_phpdir}" \
+ || : Temporarily ignore failed tests
%post
@@ -143,6 +194,15 @@ fi
%changelog
+* Sat Mar 23 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 2.2.0-1
+- Updated to 2.2.0
+- Removed tests' bootstrap patch
+- Added php-PsrLog build require
+- Added php-pear(pear.doctrine-project.org/DoctrineCommon) requires
+- Added php-mcrypt require
+- Removed php-pdo require
+- Temporarily ignore failed tests
+
* Wed Mar 06 2013 Remi Collet <remi@fedoraproject.org> - 2.2.0-1
- Update to 2.2.0