summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-06 18:33:21 +0200
committerRemi Collet <fedora@famillecollet.com>2012-10-06 18:33:21 +0200
commit89ed47dd74175044f630fbc60f662cef343fe05f (patch)
treee92ffb0f6acd7e7bf7c256798a94730662d3fd0c
parent35139d0bbe79217c85add5cd68485e50b3481046 (diff)
php-symfony2-Security 2.1.2
-rw-r--r--bootstrap.php24
-rw-r--r--php-symfony2-Security.spec31
2 files changed, 53 insertions, 2 deletions
diff --git a/bootstrap.php b/bootstrap.php
new file mode 100644
index 0000000..329fef2
--- /dev/null
+++ b/bootstrap.php
@@ -0,0 +1,24 @@
+<?php
+
+/*
+ * This file is part of the Symfony package.
+ *
+ * (c) Fabien Potencier <fabien@symfony.com>
+ *
+ * For the full copyright and license information, please view the LICENSE
+ * file that was distributed with this source code.
+ */
+
+date_default_timezone_set('UTC');
+spl_autoload_register(function ($class) {
+ if (0 === strpos(ltrim($class, '/'), 'Symfony\Component')) {
+ $file = substr(str_replace('\\', '/', $class), strlen('Symfony\Component')).'.php';
+ if (file_exists(__DIR__.'/../..'.$file)) {
+ # Run from source tree
+ require_once __DIR__.'/../..'.$file;
+ } else {
+ # Run from install dir
+ require_once 'Symfony/Component'.$file;
+ }
+ }
+});
diff --git a/php-symfony2-Security.spec b/php-symfony2-Security.spec
index f0ff360..56e8083 100644
--- a/php-symfony2-Security.spec
+++ b/php-symfony2-Security.spec
@@ -1,10 +1,11 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
%global pear_channel pear.symfony.com
%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
Name: php-symfony2-Security
-Version: 2.0.17
+Version: 2.1.2
Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
@@ -12,11 +13,19 @@ Group: Development/Libraries
License: MIT
URL: http://symfony.com/components
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+Source1: bootstrap.php
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
+# For tests
+BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
+BuildRequires: php-pear(%{pear_channel}/HttpKernel)
+BuildRequires: php-pear(%{pear_channel}/HttpFoundation)
+BuildRequires: php-pear(%{pear_channel}/EventDispatcher)
+BuildRequires: php-pear(%{pear_channel}/Form)
+BuildRequires: php-pear(%{pear_channel}/Routing)
Requires: php-common >= 5.3.2
Requires: php-pear(PEAR)
@@ -54,6 +63,14 @@ Optional dependencies: DoctrineCommon and DoctrineDBAL
%prep
%setup -q -c
+
+# Hum...
+sed -e '/CHANGELOG.md/s/role="php"/role="doc"/' \
+ -e '/phpunit.xml.dist/s/role="php"/role="test"/' \
+ -e '/Tests/s/role="php"/role="test"/' \
+ -e '/.gitignore/d' \
+ -i package.xml
+
# package.xml is version 2.0
mv package.xml %{pear_name}-%{version}/%{name}.xml
@@ -67,13 +84,19 @@ cd %{pear_name}-%{version}
%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
# Install XML package description
mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+%check
+cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}/Tests
+cp %{SOURCE1} bootstrap.php
+phpunit --bootstrap bootstrap.php --verbose .
+
+
%post
%{__pear} install --nodeps --soft --force --register-only \
%{pear_xmldir}/%{name}.xml >/dev/null || :
@@ -91,9 +114,13 @@ fi
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Symfony/Component/%{pear_name}
+%{pear_testdir}/%{pear_name}
%changelog
+* Sat Oct 6 2012 Remi Collet <RPMS@FamilleCollet.com> 2.1.2-1
+- update to 2.1.2
+
* Sat Sep 15 2012 Remi Collet <RPMS@FamilleCollet.com> 2.0.17-1
- Update to 2.0.17, backport for remi repository