summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-10-19 08:03:07 +0200
committerRemi Collet <fedora@famillecollet.com>2013-10-19 08:03:07 +0200
commit3471603ed39f807dbbb4cf98721b051de4fbc312 (patch)
treee654c971c6c4bd16f4afeb8908092ca0e745e8ad
parent923245254f799759289337853ad3794c6f5f6dae (diff)
symfony2: cleanups (dep from composer)HEADmaster
-rw-r--r--php-symfony2-Routing.spec23
1 files changed, 8 insertions, 15 deletions
diff --git a/php-symfony2-Routing.spec b/php-symfony2-Routing.spec
index f5d393c..2fa351f 100644
--- a/php-symfony2-Routing.spec
+++ b/php-symfony2-Routing.spec
@@ -19,18 +19,13 @@ BuildArch: noarch
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
-%if %{with_tests}
# For tests
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
-BuildRequires: php-pear(%{pear_channel}/Config) > 2.3
-BuildRequires: php-pear(%{pear_channel}/Config) < 2.4
-BuildRequires: php-pear(%{pear_channel}/Yaml) > 2.3
-BuildRequires: php-pear(%{pear_channel}/Yaml) < 2.4
-BuildRequires: php-pear(pear.doctrine-project.org/DoctrineCommon) >= 2.2.0
-BuildRequires: php-pear(pear.doctrine-project.org/DoctrineCommon) < 3.0.0
-BuildRequires: php-PsrLog >= 1.0
-BuildRequires: php-PsrLog < 2.0
+BuildRequires: php-pear(%{pear_channel}/Config) > 2.2
+BuildRequires: php-pear(%{pear_channel}/Yaml) > 2.0
+BuildRequires: php-pear(pear.doctrine-project.org/DoctrineCommon) > 2.2
+BuildRequires: php-PsrLog > 1.0
# For tests: phpci
BuildRequires: php-dom
BuildRequires: php-pcre
@@ -50,12 +45,10 @@ Requires: php-reflection
Requires: php-spl
Requires: php-tokenizer
# Optional
-Requires: php-pear(%{pear_channel}/Config) > 2.3
-Requires: php-pear(%{pear_channel}/Config) < 2.4
-Requires: php-pear(%{pear_channel}/Yaml) > 2.3
-Requires: php-pear(%{pear_channel}/Yaml) < 2.4
-Requires: php-pear(pear.doctrine-project.org/DoctrineCommon) >= 2.2.0
-Requires: php-pear(pear.doctrine-project.org/DoctrineCommon) < 3.0.0
+Requires: php-pear(%{pear_channel}/Config) > 2.2
+Requires: php-pear(%{pear_channel}/Yaml) > 2.0
+Requires: php-pear(pear.doctrine-project.org/DoctrineCommon) > 2.2
+Requires: php-PsrLog > 1.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}