summaryrefslogtreecommitdiffstats
path: root/php-symfony2-Process.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-06 16:51:46 +0200
committerRemi Collet <fedora@famillecollet.com>2012-10-06 16:51:46 +0200
commit5e855b4c6e2763f436e67f0adc2967708017c996 (patch)
treeeccda4625faf2dd7fa15d5a36083e1c860fc991f /php-symfony2-Process.spec
parent791983146210212ff34595f3097b60dfc23a3d2c (diff)
php-symfony2-Process 2.1.2
Diffstat (limited to 'php-symfony2-Process.spec')
-rw-r--r--php-symfony2-Process.spec25
1 files changed, 23 insertions, 2 deletions
diff --git a/php-symfony2-Process.spec b/php-symfony2-Process.spec
index fde90a6..e01a5a7 100644
--- a/php-symfony2-Process.spec
+++ b/php-symfony2-Process.spec
@@ -1,10 +1,11 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
%global pear_channel pear.symfony.com
%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
Name: php-symfony2-Process
-Version: 2.0.17
+Version: 2.1.2
Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
@@ -12,11 +13,14 @@ Group: Development/Libraries
License: MIT
URL: http://symfony.com/doc/current/components/process.html
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+Source1: bootstrap.php
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
+# For tests
+BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
Requires: php-common >= 5.3.2
Requires: php-pear(PEAR)
@@ -34,6 +38,13 @@ The Process Component executes commands in sub-processes.
%prep
%setup -q -c
+
+# Hum...
+sed -e '/CHANGELOG.md/s/role="php"/role="doc"/' \
+ -e '/phpunit.xml.dist/s/role="php"/role="test"/' \
+ -e '/Tests/s/role="php"/role="test"/' \
+ -i package.xml
+
# package.xml is version 2.0
mv package.xml %{pear_name}-%{version}/%{name}.xml
@@ -47,13 +58,19 @@ cd %{pear_name}-%{version}
%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
# Install XML package description
mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+%check
+cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}/Tests
+cp %{SOURCE1} bs.php
+phpunit --bootstrap bs.php .
+
+
%post
%{__pear} install --nodeps --soft --force --register-only \
%{pear_xmldir}/%{name}.xml >/dev/null || :
@@ -73,9 +90,13 @@ fi
%dir %{pear_phpdir}/Symfony
%dir %{pear_phpdir}/Symfony/Component
%{pear_phpdir}/Symfony/Component/%{pear_name}
+ %{pear_testdir}/%{pear_name}
%changelog
+* Sat Oct 6 2012 Remi Collet <RPMS@FamilleCollet.com> 2.1.2-1
+- update to 2.1.2
+
* Sat Sep 15 2012 Remi Collet <RPMS@FamilleCollet.com> 2.0.17-1
- Update to 2.0.17, backport for remi repository