summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-symfony2-Locale-tests-bootstrap.patch55
-rw-r--r--php-symfony2-Locale.spec22
2 files changed, 12 insertions, 65 deletions
diff --git a/php-symfony2-Locale-tests-bootstrap.patch b/php-symfony2-Locale-tests-bootstrap.patch
deleted file mode 100644
index 09e23ed..0000000
--- a/php-symfony2-Locale-tests-bootstrap.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- Symfony/Component/Locale/Tests/bootstrap.php 2012-09-20 03:42:14.000000000 -0400
-+++ Symfony/Component/Locale/Tests/bootstrap.php 2012-10-20 15:25:42.739326649 -0400
-@@ -10,17 +10,47 @@
- */
-
- if (!function_exists('intl_get_error_code')) {
-- require_once __DIR__.'/../Resources/stubs/functions.php';
-+ $file = 'Resources/stubs/functions.php';
-+ if (file_exists(__DIR__.'/../'.$file)) {
-+ require_once __DIR__.'/../'.$file;
-+ } else {
-+ try {
-+ // Try loading from include path
-+ require_once 'Symfony/Component/Locale/'.$file;
-+ } catch (Exception $e) {
-+ // Fail silently so class not found fatal error still raised
-+ }
-+ }
- }
-
- spl_autoload_register(function ($class) {
- if (in_array(ltrim($class, '/'), array('Collator', 'IntlDateFormatter', 'Locale', 'NumberFormatter'))) {
-- require_once __DIR__.'/../Resources/stubs/'.ltrim($class, '/').'.php';
-+ $file = 'Resources/stubs/'.ltrim($class, '/').'.php';
-+ if (file_exists(__DIR__.'/../'.$file)) {
-+ // Load from source tree
-+ require_once __DIR__.'/../'.$file;
-+ } else {
-+ try {
-+ // Try loading from include path
-+ require_once 'Symfony/Component/Locale/'.$file;
-+ } catch (Exception $e) {
-+ // Fail silently so class not found fatal error still raised
-+ }
-+ }
- }
-
-- if (0 === strpos(ltrim($class, '/'), 'Symfony\Component\Locale')) {
-- if (file_exists($file = __DIR__.'/../'.substr(str_replace('\\', '/', $class), strlen('Symfony\Component\Locale')).'.php')) {
-- require_once $file;
-+ if (0 === strpos(ltrim($class, '/'), 'Symfony\Component')) {
-+ $file = substr(str_replace('\\', '/', $class), strlen('Symfony\Component')).'.php';
-+ if (file_exists(__DIR__.'/../..'.$file)) {
-+ // Load from source tree
-+ require_once __DIR__.'/../..'.$file;
-+ } else {
-+ try {
-+ // Try loading from incude path
-+ require_once 'Symfony/Component'.$file;
-+ } catch (Exception $e) {
-+ // Fail silently so class not found fatal error still raised
-+ }
- }
- }
- });
diff --git a/php-symfony2-Locale.spec b/php-symfony2-Locale.spec
index ed7edd9..951cf15 100644
--- a/php-symfony2-Locale.spec
+++ b/php-symfony2-Locale.spec
@@ -7,7 +7,7 @@
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
Name: php-symfony2-Locale
-Version: 2.1.8
+Version: 2.2.0
Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
@@ -15,7 +15,6 @@ Group: Development/Libraries
License: MIT
URL: http://symfony.com/doc/current/components/locale.html
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Patch0: %{name}-tests-bootstrap.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -72,11 +71,6 @@ Stub implementation only supports the en locale.
%prep
%setup -q -c
-# Patches
-cd %{pear_name}-%{version}
-%patch0 -p0
-cd ..
-
# Modify PEAR package.xml file:
# - Remove .gitignore file
# - Change role from "php" to "doc" for UPDATE.txt file
@@ -88,7 +82,6 @@ sed -e '/\.gitignore/d' \
-e '/CHANGELOG.md/s/role="php"/role="doc"/' \
-e '/phpunit.xml.dist/s/role="php"/role="test"/' \
-e '/Tests/s/role="php"/role="test"/' \
- -e '/bootstrap.php/s/md5sum="[^"]*"\s*//' \
-e '/.git/d' \
-i package.xml
@@ -120,11 +113,17 @@ sed -i "s#) %{buildroot}#) #" ../%{name}.lang
mkdir -p %{buildroot}%{pear_xmldir}
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+sed -e '/bootstrap/s:vendor/autoload.php:%{pear_phpdir}/Symfony/Component/%{pear_name}/autoloader.php:' \
+ %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml.dist \
+ > %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml
+
%check
%if %{with_tests}
- cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
- %{_bindir}/phpunit
+cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
+sed -e '/bootstrap/s:vendor/autoload.php:autoloader.php:' \
+ phpunit.xml.dist > phpunit.xml
+%{_bindir}/phpunit -d date.timezone=UTC
%else
: Tests skipped, missing '--with tests' option
%endif
@@ -167,6 +166,9 @@ fi
%changelog
+* Wed Mar 06 2013 Remi Collet <remi@fedoraproject.org> - 2.2.0-1
+- Update to 2.2.0
+
* Wed Feb 27 2013 Remi Collet <remi@fedoraproject.org> - 2.1.8-1
- Update to 2.1.8