summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-06 09:56:28 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-06 09:56:28 +0100
commit5b98e5220c4d14cd9ada07173a889186bf055aa4 (patch)
tree67351707496a6581988ba3de8d85213e0afb998d
parent727a3c2d098f48e645506e09bc6e5b29fbe59c75 (diff)
php-symfony2-HttpFoundation: 2.2.0
-rw-r--r--php-symfony2-HttpFoundation-tests-bootstrap.patch44
-rw-r--r--php-symfony2-HttpFoundation.spec30
2 files changed, 12 insertions, 62 deletions
diff --git a/php-symfony2-HttpFoundation-tests-bootstrap.patch b/php-symfony2-HttpFoundation-tests-bootstrap.patch
deleted file mode 100644
index b64af48..0000000
--- a/php-symfony2-HttpFoundation-tests-bootstrap.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- Symfony/Component/HttpFoundation/Tests/bootstrap.php 2012-09-20 03:42:11.000000000 -0400
-+++ Symfony/Component/HttpFoundation/Tests/bootstrap.php 2012-10-21 00:45:21.962629147 -0400
-@@ -9,14 +9,38 @@
- * file that was distributed with this source code.
- */
-
-+date_default_timezone_set('UTC');
- spl_autoload_register(function ($class) {
- if (ltrim('SessionHandlerInterface', '/') === $class) {
-- require_once __DIR__.'/../Resources/stubs/SessionHandlerInterface.php';
-+ $file = '/Resources/stubs/SessionHandlerInterface.php';
-+ if (file_exists(__DIR__.'/..'.$file)) {
-+ // Load from source tree
-+ require_once __DIR__.'/..'.$file;
-+ } else {
-+ try {
-+ // Try loading from include path
-+ require_once 'Symfony/Component/HttpFoundation'.$file;
-+ } catch (Exception $e) {
-+ // Fail silently so class not found fatal error still raised
-+ }
-+ }
- }
-
-- if (0 !== strpos(ltrim($class, '/'), 'Symfony\Component\HttpFoundation')) {
-+ if (0 !== strpos(ltrim($class, '/'), 'Symfony\Component')) {
- return;
- }
-
-- require_once __DIR__.'/../'.substr(str_replace('\\', '/', $class), strlen('Symfony\Component\HttpFoundation')).'.php';
-+ $file = substr(str_replace('\\', '/', $class), strlen('Symfony\Component')).'.php';
-+
-+ if (file_exists(__DIR__.'/../..'.$file)) {
-+ // Load from source tree
-+ require_once __DIR__.'/../..'.$file;
-+ } else {
-+ try {
-+ // Try loading from incude path
-+ require_once 'Symfony/Component'.$file;
-+ } catch (Exception $e) {
-+ // Fail silently so class not found fatal error still raised
-+ }
-+ }
- });
diff --git a/php-symfony2-HttpFoundation.spec b/php-symfony2-HttpFoundation.spec
index 14d948e..1dc003d 100644
--- a/php-symfony2-HttpFoundation.spec
+++ b/php-symfony2-HttpFoundation.spec
@@ -3,11 +3,9 @@
%global pear_channel pear.symfony.com
%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
%global php_min_ver 5.3.3
-# Temp disable tests by default b/c build failures on F18, F17, and EL6
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
Name: php-symfony2-HttpFoundation
-Version: 2.1.8
+Version: 2.2.0
Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
@@ -15,13 +13,11 @@ Group: Development/Libraries
License: MIT
URL: http://symfony.com/doc/current/components/http_foundation/index.html
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Patch0: %{name}-tests-bootstrap.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
-%if %{with_tests}
# Test requires
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
@@ -36,7 +32,6 @@ BuildRequires: php-session
BuildRequires: php-sockets
BuildRequires: php-spl
BuildRequires: php-filter
-%endif
Requires: php(language) >= %{php_min_ver}
Requires: php-pear(PEAR)
@@ -74,11 +69,6 @@ Optional dependencies: memcache, memcached, mongo
%prep
%setup -q -c
-# Patches
-cd %{pear_name}-%{version}
-%patch0 -p0
-cd ..
-
# Modify PEAR package.xml file:
# - Remove .gitignore file
# - Change role from "php" to "doc" for CHANGELOG.md file
@@ -88,7 +78,6 @@ sed -e '/\.gitignore/d' \
-e '/CHANGELOG.md/s/role="php"/role="doc"/' \
-e '/phpunit.xml.dist/s/role="php"/role="test"/' \
-e '/Tests/s/role="php"/role="test"/' \
- -e '/bootstrap.php/s/md5sum="[^"]*"\s*//' \
-i package.xml
# package.xml is version 2.0
@@ -110,14 +99,16 @@ rm -rf %{buildroot}%{pear_metadir}/.??*
mkdir -p %{buildroot}%{pear_xmldir}
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+sed -e '/bootstrap/s:vendor/autoload.php:%{pear_phpdir}/Symfony/Component/%{pear_name}/autoloader.php:' \
+ %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml.dist \
+ > %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml
+
%check
-%if %{with_tests}
- cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
- %{_bindir}/phpunit
-%else
-: Tests skipped, missing '--with tests' option
-%endif
+cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
+sed -e '/bootstrap/s:vendor/autoload.php:autoloader.php:' \
+ phpunit.xml.dist > phpunit.xml
+%{_bindir}/phpunit -d date.timezone=UTC \
%post
@@ -143,6 +134,9 @@ fi
%changelog
+* Wed Mar 06 2013 Remi Collet <remi@fedoraproject.org> - 2.2.0-1
+- Update to 2.2.0
+
* Wed Feb 27 2013 Remi Collet <remi@fedoraproject.org> - 2.1.8-1
- Update to 2.1.8