summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-30 18:46:51 +0100
committerRemi Collet <fedora@famillecollet.com>2012-10-30 18:46:51 +0100
commit41c0c755eafacc3ddc5527b0c6f6f41f6226c6c1 (patch)
tree78e01baffd10e7e4780c065481599d65e6e975af
parentf6e50f8592397ddb9ea62f1f23c8c06aac164cd6 (diff)
php-symfony2-Finder: sync with rawhide, update to 2.1.3
-rw-r--r--bootstrap.php24
-rw-r--r--php-symfony2-Finder-tests-bootstrap.patch26
-rw-r--r--php-symfony2-Finder.spec63
3 files changed, 73 insertions, 40 deletions
diff --git a/bootstrap.php b/bootstrap.php
deleted file mode 100644
index 329fef2..0000000
--- a/bootstrap.php
+++ /dev/null
@@ -1,24 +0,0 @@
-<?php
-
-/*
- * This file is part of the Symfony package.
- *
- * (c) Fabien Potencier <fabien@symfony.com>
- *
- * For the full copyright and license information, please view the LICENSE
- * file that was distributed with this source code.
- */
-
-date_default_timezone_set('UTC');
-spl_autoload_register(function ($class) {
- if (0 === strpos(ltrim($class, '/'), 'Symfony\Component')) {
- $file = substr(str_replace('\\', '/', $class), strlen('Symfony\Component')).'.php';
- if (file_exists(__DIR__.'/../..'.$file)) {
- # Run from source tree
- require_once __DIR__.'/../..'.$file;
- } else {
- # Run from install dir
- require_once 'Symfony/Component'.$file;
- }
- }
-});
diff --git a/php-symfony2-Finder-tests-bootstrap.patch b/php-symfony2-Finder-tests-bootstrap.patch
new file mode 100644
index 0000000..b1ef71e
--- /dev/null
+++ b/php-symfony2-Finder-tests-bootstrap.patch
@@ -0,0 +1,26 @@
+--- Symfony/Component/Finder/Tests/bootstrap.php 2012-09-20 03:42:09.000000000 -0400
++++ Symfony/Component/Finder/Tests/bootstrap.php 2012-10-20 14:34:00.221837022 -0400
+@@ -9,10 +9,20 @@
+ * file that was distributed with this source code.
+ */
+
++date_default_timezone_set('UTC');
+ spl_autoload_register(function ($class) {
+- if (0 === strpos(ltrim($class, '/'), 'Symfony\Component\Finder')) {
+- if (file_exists($file = __DIR__.'/../'.substr(str_replace('\\', '/', $class), strlen('Symfony\Component\Finder')).'.php')) {
+- require_once $file;
++ if (0 === strpos(ltrim($class, '/'), 'Symfony\Component')) {
++ $file = substr(str_replace('\\', '/', $class), strlen('Symfony\Component')).'.php';
++ if (file_exists(__DIR__.'/../..'.$file)) {
++ // Load from source tree
++ require_once __DIR__.'/../..'.$file;
++ } else {
++ try {
++ // Try loading from incude path
++ require_once 'Symfony/Component'.$file;
++ } catch (Exception $e) {
++ // Fail silently so class not found fatal error still raised
++ }
+ }
+ }
+ });
diff --git a/php-symfony2-Finder.spec b/php-symfony2-Finder.spec
index 615369a..73fe87b 100644
--- a/php-symfony2-Finder.spec
+++ b/php-symfony2-Finder.spec
@@ -1,28 +1,34 @@
-%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%global pear_channel pear.symfony.com
%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
+%global php_min_ver 5.3.3
Name: php-symfony2-Finder
-Version: 2.1.2
-Release: 2%{?dist}
+Version: 2.1.3
+Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
Group: Development/Libraries
License: MIT
URL: http://symfony.com/doc/current/components/finder.html
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Source1: bootstrap.php
+Patch0: %{name}-tests-bootstrap.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
-# For tests
+# Test requires
+BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
+# Test requires: phpci
+BuildRequires: php-date
+BuildRequires: php-pcre
+BuildRequires: php-spl
-Requires: php-common >= 5.3.2
+Requires: php(language) >= %{php_min_ver}
Requires: php-pear(PEAR)
Requires: php-channel(%{pear_channel})
Requires(post): %{__pear}
@@ -42,10 +48,20 @@ interface.
%prep
%setup -q -c
-# Hum...
+# Patches
+cd %{pear_name}-%{version}
+%patch0 -p0
+cd ..
+
+# Modify PEAR package.xml file:
+# - Change role from "php" to "doc" for CHANGELOG.md file
+# - Change role from "php" to "test" for all test files
+# - Remove md5sum from bootsrap.php file since it was patched
sed -e '/CHANGELOG.md/s/role="php"/role="doc"/' \
+ -e '/.git/d' \
-e '/phpunit.xml.dist/s/role="php"/role="test"/' \
-e '/Tests/s/role="php"/role="test"/' \
+ -e '/bootstrap.php/s/md5sum="[^"]*"\s*//' \
-i package.xml
# package.xml is version 2.0
@@ -53,25 +69,24 @@ mv package.xml %{pear_name}-%{version}/%{name}.xml
%build
-# Empty build section, nothing required.
+# Empty build section, nothing required
%install
cd %{pear_name}-%{version}
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
-cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}/Tests
-cp %{SOURCE1} bootstrap.php
-phpunit --bootstrap bootstrap.php --verbose .
+cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
+%{_bindir}/phpunit
%post
@@ -93,10 +108,26 @@ fi
%dir %{pear_phpdir}/Symfony
%dir %{pear_phpdir}/Symfony/Component
%{pear_phpdir}/Symfony/Component/%{pear_name}
- %{pear_testdir}/%{pear_name}
+%{pear_testdir}/%{pear_name}
%changelog
+* Tue Oct 30 2012 Remi Collet <RPMS@FamilleCollet.com> 2.1.3-1
+- sync with rawhide, update to 2.1.3
+
+* Mon Oct 29 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.1.2-2
+- Added "%%global pear_metadir" and usage in %%install
+- Changed RPM_BUILD_ROOT to %%{buildroot}
+- Changed name of patch from "php-symfony2-Finder-tests-bootstrap.patch" to
+ "%%{name}-tests-bootstrap.patch"
+
+* Fri Oct 19 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.1.2-1
+- Updated to upstream version 2.1.2
+- PHP minimum version 5.3.3 instead of 5.3.2
+- Added PEAR package.xml modifications
+- Added patch for tests' bootstrap.php
+- Added tests (%%check)
+
* Sat Oct 6 2012 Remi Collet <RPMS@FamilleCollet.com> 2.1.2-2
- rebuild