summaryrefslogtreecommitdiffstats
path: root/php-symfony2-Filesystem.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-06 18:39:12 +0200
committerRemi Collet <fedora@famillecollet.com>2012-10-06 18:39:12 +0200
commit92a7b53a62dcae52ab6d5536be600a104ee20095 (patch)
treedd9e504a6c3b6b2ae533e97780cd72c3090c0aba /php-symfony2-Filesystem.spec
parent0cc5c72888154999b67c76a6d6d9bc70204b9d7e (diff)
php-symfony2-Filesystem: build, with tests
Diffstat (limited to 'php-symfony2-Filesystem.spec')
-rw-r--r--php-symfony2-Filesystem.spec26
1 files changed, 25 insertions, 1 deletions
diff --git a/php-symfony2-Filesystem.spec b/php-symfony2-Filesystem.spec
index 85d1279..cda86ce 100644
--- a/php-symfony2-Filesystem.spec
+++ b/php-symfony2-Filesystem.spec
@@ -1,3 +1,4 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
%global pear_channel pear.symfony.com
@@ -12,10 +13,14 @@ Group: Development/Libraries
License: MIT
URL: http://symfony.com/doc/current/components/filesystem.html
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+Source1: bootstrap.php
BuildArch: noarch
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
+# For tests
+BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
+BuildRequires: php-posix
Requires: php-common >= 5.3.2
Requires: php-pear(PEAR)
@@ -25,6 +30,7 @@ Requires(postun): %{__pear}
# phpci requires
Requires: php-ctype
Requires: php-date
+Requires: php-posix
Requires: php-spl
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -35,6 +41,14 @@ The Filesystem component provides basic utilities for the filesystem.
%prep
%setup -q -c
+
+# Hum...
+sed -e '/CHANGELOG.md/s/role="php"/role="doc"/' \
+ -e '/phpunit.xml.dist/s/role="php"/role="test"/' \
+ -e '/Tests/s/role="php"/role="test"/' \
+ -e '/.gitignore/d' \
+ -i package.xml
+
# package.xml is version 2.0
mv package.xml %{pear_name}-%{version}/%{name}.xml
@@ -48,13 +62,19 @@ cd %{pear_name}-%{version}
%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
# Install XML package description
mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+%check
+cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}/Tests
+cp %{SOURCE1} bootstrap.php
+phpunit --bootstrap bootstrap.php --verbose .
+
+
%post
%{__pear} install --nodeps --soft --force --register-only \
%{pear_xmldir}/%{name}.xml >/dev/null || :
@@ -73,8 +93,12 @@ fi
%dir %{pear_phpdir}/Symfony
%dir %{pear_phpdir}/Symfony/Component
%{pear_phpdir}/Symfony/Component/%{pear_name}
+%{pear_testdir}/%{pear_name}
%changelog
+* Sat Oct 6 2012 Remi Collet <RPMS@FamilleCollet.com> 2.1.2-1
+- update to 2.1.2
+
* Thu Sep 20 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.1.2-1
- Initial package