summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-06 18:33:40 +0200
committerRemi Collet <fedora@famillecollet.com>2012-10-06 18:33:40 +0200
commit0cc5c72888154999b67c76a6d6d9bc70204b9d7e (patch)
treeefe8bd220f52e01e8990cf6e657b377219d9cd32
php-symfony2-Filesystem: import from review
-rw-r--r--php-symfony2-Filesystem.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/php-symfony2-Filesystem.spec b/php-symfony2-Filesystem.spec
new file mode 100644
index 0000000..85d1279
--- /dev/null
+++ b/php-symfony2-Filesystem.spec
@@ -0,0 +1,80 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+
+%global pear_channel pear.symfony.com
+%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
+
+Name: php-symfony2-Filesystem
+Version: 2.1.2
+Release: 1%{?dist}
+Summary: Symfony2 %{pear_name} Component
+
+Group: Development/Libraries
+License: MIT
+URL: http://symfony.com/doc/current/components/filesystem.html
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+BuildRequires: php-channel(%{pear_channel})
+
+Requires: php-common >= 5.3.2
+Requires: php-pear(PEAR)
+Requires: php-channel(%{pear_channel})
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+# phpci requires
+Requires: php-ctype
+Requires: php-date
+Requires: php-spl
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+%description
+The Filesystem component provides basic utilities for the filesystem.
+
+
+%prep
+%setup -q -c
+# package.xml is version 2.0
+mv package.xml %{pear_name}-%{version}/%{name}.xml
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+
+# Clean up unnecessary files
+rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+
+# Install XML package description
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%dir %{pear_phpdir}/Symfony
+%dir %{pear_phpdir}/Symfony/Component
+ %{pear_phpdir}/Symfony/Component/%{pear_name}
+
+
+%changelog
+* Thu Sep 20 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.1.2-1
+- Initial package