summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-12 17:35:41 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-12 17:35:41 +0200
commit05c764a886f04f8136ac3a3da11bb177d1b7af26 (patch)
treeea3d3309a3eb0b7b4c8389ea17df687c71a6e8a9
php-symfony2-EventDispatcher: import from rawhide
-rw-r--r--Makefile4
-rw-r--r--php-symfony2-EventDispatcher.spec118
2 files changed, 122 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-symfony2-EventDispatcher.spec b/php-symfony2-EventDispatcher.spec
new file mode 100644
index 0000000..f1cd3c7
--- /dev/null
+++ b/php-symfony2-EventDispatcher.spec
@@ -0,0 +1,118 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_channel pear.symfony.com
+%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
+
+Name: php-symfony2-EventDispatcher
+Version: 2.0.15
+Release: 1%{?dist}
+Summary: Symfony2 %{pear_name} Component
+
+Group: Development/Libraries
+License: MIT
+URL: http://symfony.com/doc/current/components/event_dispatcher/introduction.html
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+BuildRequires: php-channel(%{pear_channel})
+
+Requires: php-common >= 5.3.2
+Requires: php-pear(PEAR)
+Requires: php-channel(%{pear_channel})
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+%description
+The Symfony2 Event Dispatcher component implements the Observer
+(http://en.wikipedia.org/wiki/Observer_pattern) pattern in a simple and
+effective way to make all these things possible and to make your projects
+truly extensible.
+
+Take a simple example from the Symfony2 HttpKernel component. Once a Response
+object has been created, it may be useful to allow other elements in the system
+to modify it (e.g. add some cache headers) before it's actually used. To make
+this possible, the Symfony2 kernel throws an event - kernel.response. Here's
+how it works:
+
+* A listener (PHP object) tells a central dispatcher object that it wants to
+ listen to the kernel.response event;
+* At some point, the Symfony2 kernel tells the dispatcher object to dispatch
+ the kernel.response event, passing with it an Event object that has access to
+ the Response object;
+* The dispatcher notifies (i.e. calls a method on) all listeners of the
+ kernel.response event, allowing each of them to make modifications to the
+ Response object.
+
+
+%prep
+%setup -q -c
+# package.xml is version 2.0
+mv package.xml %{pear_name}-%{version}/%{name}.xml
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+
+# Clean up unnecessary files
+rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+
+# Install XML package description
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Symfony/Component/%{pear_name}
+%dir %{pear_phpdir}/Symfony/Component
+%dir %{pear_phpdir}/Symfony
+
+
+%changelog
+* Wed May 30 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.0.15-1
+- Updated to upstream version 2.0.15
+- Removed "BuildRequires: php-pear >= 1:1.4.9-1.2"
+- Updated %%prep section
+- Removed cleaning buildroot from %%install section
+- Removed documentation move from %%install section (fixed upstream)
+- Removed %%clean section
+- Updated %%doc in %%files section
+
+* Sun May 20 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.0.14-3
+- Moved documentation to correct location
+
+* Sun May 20 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.0.14-2
+- Removed BuildRoot
+- Changed php require to php-common
+- Removed %%defattr from %%files section
+
+* Fri May 18 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.0.14-1
+- Updated to upstream version 2.0.14
+- %%global instead of %%define
+- Removed unnecessary cd from %%build section
+
+* Wed May 2 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.0.13-1
+- Updated to upstream version 2.0.13
+
+* Sat Apr 21 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.0.12-1
+- Initial package