summaryrefslogtreecommitdiffstats
path: root/php-symfony2-DependencyInjection.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-30 18:30:49 +0100
committerRemi Collet <fedora@famillecollet.com>2012-10-30 18:30:49 +0100
commitcd1be1943621c419b338284818d1fc1759d823d5 (patch)
tree9f68997c93ab3edaad7fec6ecf08e2a8cfbe4c37 /php-symfony2-DependencyInjection.spec
parent0e3d6d2fddbb61076e812aab93d67d66457ee2ba (diff)
php-symfony2-DependencyInjection: sync with rawhide, update to 2.1.3
Diffstat (limited to 'php-symfony2-DependencyInjection.spec')
-rw-r--r--php-symfony2-DependencyInjection.spec77
1 files changed, 57 insertions, 20 deletions
diff --git a/php-symfony2-DependencyInjection.spec b/php-symfony2-DependencyInjection.spec
index dd22643..ab6df90 100644
--- a/php-symfony2-DependencyInjection.spec
+++ b/php-symfony2-DependencyInjection.spec
@@ -1,11 +1,12 @@
-%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%global pear_channel pear.symfony.com
%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
+%global php_min_ver 5.3.3
Name: php-symfony2-DependencyInjection
-Version: 2.1.2
+Version: 2.1.3
Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
@@ -13,18 +14,28 @@ Group: Development/Libraries
License: MIT
URL: http://symfony.com/doc/current/components/dependency_injection/index.html
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Source1: bootstrap.php
+Patch0: %{name}-tests-bootstrap.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
-# For tests
+# Test requires
+BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
-BuildRequires: php-pear(%{pear_channel}/Config)
-BuildRequires: php-pear(%{pear_channel}/Yaml)
-
-Requires: php-common >= 5.3.2
+BuildRequires: php-pear(%{pear_channel}/Config) >= 2.1.0
+BuildRequires: php-pear(%{pear_channel}/Yaml) >= 2.1.0
+# Test requires: phpci
+BuildRequires: php-ctype
+BuildRequires: php-dom
+BuildRequires: php-libxml
+BuildRequires: php-pcre
+BuildRequires: php-phar
+BuildRequires: php-reflection
+BuildRequires: php-simplexml
+BuildRequires: php-spl
+
+Requires: php(language) >= %{php_min_ver}
Requires: php-pear(PEAR)
Requires: php-channel(%{pear_channel})
Requires(post): %{__pear}
@@ -34,12 +45,13 @@ Requires: php-ctype
Requires: php-dom
Requires: php-libxml
Requires: php-pcre
+Requires: php-phar
Requires: php-reflection
Requires: php-simplexml
Requires: php-spl
# Optional requires
-Requires: php-pear(%{pear_channel}/Config) = %{version}
-Requires: php-pear(%{pear_channel}/Yaml) = %{version}
+Requires: php-pear(%{pear_channel}/Config) >= 2.1.0
+Requires: php-pear(%{pear_channel}/Yaml) >= 2.1.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -54,11 +66,21 @@ Service Container (http://symfony.com/doc/current/book/service_container.html).
%prep
%setup -q -c
-# Hum...
-sed -e '/CHANGELOG.md/s/role="php"/role="doc"/' \
+# Patches
+cd %{pear_name}-%{version}
+%patch0 -p0
+cd ..
+
+# Modify PEAR package.xml file:
+# - Remove .gitignore file
+# - Change role from "php" to "doc" for CHANGELOG.md file
+# - Change role from "php" to "test" for all test files
+# - Remove md5sum from bootsrap.php file since it was patched
+sed -e '/.git/d' \
+ -e '/CHANGELOG.md/s/role="php"/role="doc"/' \
-e '/phpunit.xml.dist/s/role="php"/role="test"/' \
-e '/Tests/s/role="php"/role="test"/' \
- -e '/.gitignore/d' \
+ -e '/bootstrap.php/s/md5sum="[^"]*"\s*//' \
-i package.xml
# package.xml is version 2.0
@@ -71,20 +93,19 @@ mv package.xml %{pear_name}-%{version}/%{name}.xml
%install
cd %{pear_name}-%{version}
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
-cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}/Tests
-cp %{SOURCE1} bs.php
-phpunit --bootstrap bs.php --verbose .
+cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
+%{_bindir}/phpunit
%post
@@ -108,6 +129,22 @@ fi
%changelog
+* Tue Oct 30 2012 Remi Collet <RPMS@FamilleCollet.com> 2.1.3-1
+- sync with rawhide, update to 2.1.3
+
+* Mon Oct 29 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.1.2-2
+- Added "%%global pear_metadir" and usage in %%install
+- Changed RPM_BUILD_ROOT to %%{buildroot}
+
+* Sat Oct 20 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.1.2-1
+- Updated to upstream version 2.1.2
+- PHP minimum version 5.3.3 instead of 5.3.2
+- Added php-pecl(phar) require
+- Require other components ">= 2.1.0" instead of "= %%{version}"
+- Added PEAR package.xml modifications
+- Added patch for tests' bootstrap.php
+- Added tests (%%check)
+
* Sat Oct 6 2012 Remi Collet <RPMS@FamilleCollet.com> 2.1.2-1
- update to 2.1.2